TTGO Tbeam Noob Help!

I am currently here. I bought what I assumed was meshtastic preloaded, ttgo , but doesnt seem to connect. Does that mean I have to flash again?

1 Like


this is definitely not a meshtastic preloaded device. I think this is “SoftRF” firmware.

You are right, you have to flash the fw yourself. Pretty easy, just follow the instructions on github.


oh, well and one is missing the antenna :sweat_smile:

1 Like

I am not sure if it is save to power up a device without a antenna connected.

Maybe someone has some info about this?

Regarding the missing antenna: maybe you will buy a Moxon anrenna which really does a great job.

Got it working and they both work, the antenna i assume is just for better signal strength.
Not too sure how I would go about getting a replacement, does the 923 mhz matter for a replacement antenna?

The great thing about transmitting without an antenna is that you can safely burn the lora chip definitely :sweat_smile:


welp not much i can do but break it and buy a new one cause it took more than a month to come in

You could even poke a specific length of wire into the center pin of the connector. Would be better than nothing! Around 81mm sticking out would be close for 1/4 wavelength at 923MHz. There are much better homemade antennas out there and I’m sure someone could point you in the right direction with a more technical answer.


Yeah I’m gonna look for some small cooper wire to jam in there

1 Like

Will probably work better than the supplied ones!


bummer - FWIW if you send an email to the TTGO corp acct linking to this thread, I bet they will give you some money back for the antenna and that it didn’t have the right software. I bet they’d like to know about the screwup. That won’t help with the long time required for shipping though - sorry about that.

It looks like I made it. No idea what I changed… lol

I hope its okay to attach my problem down here as it goes in the same direction:

I got two v.1.1 TBeams and tried to flash it with the EU865 file using the esphome-flasher as recommended on the meshtastic tutorial for newbees as me.

The Error I get (with different files): “Unexpected error: could not open port ‘COM5’: PermissionError(13, ‘Zugriff verweigert’, None, 5)”

What am I doing wrong? I’m new to this and I suspect that its a quiet simple mistake by me as the errors are always the same…

Thanks for your help in advance!

Welcome to the forum @Speedy and guten Abend,

is COM5 the only port in the combobox/dropdown menu? If so you probably selected the wrong com port.

Otherwise, which OS (windows, linux, mac) are you using?

Thx mate.

It all worked out 2mins after I wrote this and struggled hours before…

The ports are okay somehow, as I could flash the second one on port COM4. I’m using win10. Looked like my connection cable had some trouble, after a while it worked so thanks for your answer!

You’re welcome. Glad to hear that you made it already.

Does anyone in here were using TTGO T-BEAM 923 MHz cause I have a hard time with it. Can anyone guide me?

1 Like

Can you please explain a little more what we should guide you? :wink:

Regarding 923MHz: This frequency region is not added yet i think. I would suggest open an issue on github.

1 Like

Sorry for the late reply. The first thing i do when i got the tbeam board, i try to upload the firmware by using the esp32 software only that has been suggested but it doesnt work. So I tried to do manually by installing the gui software, and few other things and i didnt know that we need to do that. So i try again to upload the firmware and it work. It’s funny just to think about it. And regarding about the 923MHz, I was using the closer one to it which is the Japan which used 913MHz and it works just fine for now i guess. :joy: Thanks @drewsed for your concern.


in on linux how do i flash this t-beam 1.1 with meshtastic?

whats the command and where do the bin file need to be?