Absolute Noob Questions, please ignore if you're low on patience

Hi guys,

I’m one of these people who really like the idea of Meshtastic, but who can’t get it to run at all.
I’ve just received two LoRa radios from a friend (who also can’t get anything to run), which I’ve charged and one sends packets to the other, so they seem to work.
I’ve followed the instructions on meshtastic.letstalkthis.com, and after some trouble managed to download the ESP flasher and the firmware.
Now the flasher gives me an error message “no serial”. Connector is USB, and it’s in. Any ideas here?

Next, would one of you be able to tell me which firmware to choose for the LoRas on the attached picture?

Thanks in advance muchly,


Welcome to the project.

The way sellers advertise the devices tends to be rather inconsistent.

The way manufactures revise boards even more so.

Myself and others can guess what board is in the case, and come up with some ideas on what TTGO board it could be. But we would have a better idea if you can open the case and take close up photos of the actual board.


Thanks, will do when I get back inside. That makes sense.

If you are using the Windows version of ESP Flasher and no COM port shows up, try two things.

First, try another USB cable. You need a full USB cable, not just a charging cable.
Second, you may need to install the USB bridge/UART drivers.

1 Like

Re cables: Thank you very much indeed for this pointer, this made sense to me straight away, as I hadn’t thought of the type of cable at all. I tried a few other cables with no success though. The original one was included in the package and at least charges the LoRas. It has quite a long metal plug to reach into the rather thick 3d printed case, so not all other cables even reach deep enough to charge. I tried different USB ports as well, also didn’t do the trick.
Do I need to emulate a serial port? Or is this just how they phrased the error message, and I can keep trying USB?

Re ID of board: I’ve opened the case and taken some pictures. Do you guys recognise this make?

I only now saw the second part of your reply. Sorry about that. I have no idea what that is, but I’ll try to find it by search engine.

Yes, that was it. I found the driver via the forum, installed it, and now I have a connection. Thank you!!

And update:
I chose the first option on the flasher and installed the Heltec firmware on both my radios. I was able to rename the units and send text messages, however they both say “no gps module”, and not all texts are visible on both units. Inbetween, they both went to an “unset” screen and seemed unusable for a short while.
Can these issues be rooted in me choosing the wrong firmware or do these units really have no GPS (can someone tell from the pictures)?
If no-one can ID, I’d slowly test my way through the firmware options, but I’m hoping one of you can enlighten me.
Exciting. I like playing with them, but I sure wish I knew a little better what I’m doing.

1 Like

This model is a TTGO LoRa32 V1.0

1 Like

Thank you! Will reflash immediately and see if the results are better!

The TTGO lora 32 boards don’t have GPS, you need to use the t-beam boards for GPS currently. See LILYGO® TTGO Lora devices | Meshtastic for details on each board.


Thank you. Will have to use these two as infrastructure (repeaters/range extenders) then. We’re looking into getting quite a few for a network…

Where do you live? I’m working on a repeater network but I still have trouble getting proper repeater link for some reason.
I live close to Chemnitz.

Kefenrod, Oberhessen. Between Frankfurt (the other one) and Fulda. Quite a trip, unfortunately.
I’m happy to communicate though, if I can be of any assistance. If you like, send me an email via my website.

Well, I guess you’ve all helped me find out that I need different hardware to do what I want to do.
And at least I got these two things to run, albeit without the feature I was looking for.
Thank you.

@Nungu If you are using a phone and the android app with the above devices Meshtastic will attempt to get the location from the phone’s gps or location services.


Thank you for this. That would indeed help in the short term to at least be able to use the units. I’m planning to use most units on their own though, so the bulk will have to have GPS on board.
The other thing is that in the hour or so that I ran my two units yesterday connected to my phone, the system never showed anything on the map.
Do I have to set the units up differently, does it just take longer (the first time round)?

@trisp3ar Let me rephrase this: Please email me, I have a million questions. :nerd_face:

A little late to the discussion, but there is a walkthrough on flashing firmware for different OS’s in the docs Flashing Firmware | Meshtastic