Meshtastic

New Plugin - RangeTestPlugin

Hello peeps!

We have a new plugin, the Range Test Plugin. It’s highly recommended that you test this out using two tbeams with good GPS reception. If you do end up using other boards or with a paired phone, please let us know what you did so we can keep track of what works.

There is one bug that I know of and that is if you enter a double quote in the message, it’l break the generated CSV. Other than that, it does work well and is relatively stable.

For the brave, the plugin is currently in the most recent (from the 18th onward) pre-pre Alpha nightly builds:

http://www.casler.org/meshtastic/nightly_builds/

If you do install and use it, feedback would be greatly appreciated and if you find problems, there’s a good chance I’ll be able to fix it before the next official Alpha firmware. If it does work, please share your results!

To configure it, use the latest Meshtastic Python API – a new version was released a few days ago.

Here are instructions on how to use the plugin:

Here’s a sample output of the saved CSV file:

9 Likes

I really want to try this, Can’t wait for an Alpha Build…

1 Like

I tried the build from the 20th on a T-Beam as a range ‘sender’, but was getting a lot of instability as a result - random resets after a few hours, and even a complete lockup once. I did have wifi enabled at the same time (connecting to an AP), so I wondered if perhaps that was overtaxing the device. I re-flashed the ‘sender’ as well as a ‘receiver’ T-Beam this morning with today’s build, and have SoftAP enabled only on the ‘receiver’ now. Both have been up for almost 2 hours with no issues. I’ll keep an eye on them and actually try a little range testing this evening.

Nifty! The ‘sender’ T-Beam has an uptime of over 9 hours now, so the instability seems to have been resolved (not sure if the wifi was indeed the culprit - will need to do more testing). I also realized just how much the GPS location flops around - I’ll need to set the lat/long manually for the stationary ‘receiver’ and switch to the new NEO-M8N equipped T-Beam and square GPS antenna I just got for the ‘sender’ (and perhaps take notes on exactly where I am for each sequence ‘ping’).

1 Like

Another thing you (or anyone) can try is to flip the model.

Have your receiver be stationary and then you can have multiple senders.

In this setup, you can have multiple people participating in a coverage test of your mesh and it may be a more realistic configuration because you’re also testing the performance of the mesh and not just point to point.

Just a thought.

2 Likes

Oh, certainly - I’m still getting my feet wet with Meshtastic, but am enamored enough with it that I’ll be inflicting a few T-Beams on friends to see if we can test out the ‘mesh’ capability (for now, I’m just amazed with the ‘tastic’ range possible for such low transmit power and am having fun playing with LoRa in that regard).

2 Likes

How one can get the packet size of a sequence number?

1 Like

It’s sent as a regular text message. You can see the size in the logs. I think it’s somewhere between 11-14 bytes which includes all the network protocol overhead.

Could you please tell me about the command for the log?

1 Like

Open up a serial console to the port exposed the device when plugged into your computer.

Set it to 921600 baud

Actually I am asking you the linux command

Change ttyUSB3 to match your device, If your not sure what that is; plug it in, unplug it and plug it back in.

Run the following

1 Like

@satkiwii Got it. Thanks!

I can report success with sending and receiving messages between two T-Beams running version 1.1.48. I’m not able to record the test to CSV because my T-Beams only show 48443 bytes free on the internal web page.

How can I get more usable space on the filesystem to be able to capture range test to file?

48443

how did you access this page?

You can access the page via the IP address/static of the board or the mDNS name “meshtastic.local/static”.

This is the wiki to access the web page

1 Like

thanks! exactly what I needed

2 Likes

Take a look at this tread on how to update the partition table of your board. I have not tried it myself but read a few people who have done it successfully.

The spiffs-1.1.48.bin firmware fixed my partition issue and then 1.48 installed fine, but the rangetest.csv file is not auto generating for me when I turn on the plugin.

1 Like
range_test_plugin_save

Will need to be set to true. Is disabled by default.

I have it on, here are my settings for the plugin from the python API --info

range_test_plugin_enabled: true
range_test_plugin_sender: 15
range_test_plugin_save: true