Meshtastic

1.2.13 alpha of device, android and python code eagerly needs testing

Hi ya’ll,

I’ve just released new builds with the latest work of all our devs. In particular I’m eager to release a new android build to general users, but I can’t do that until a few of ya’ll bless it as “seems to work okay for me… including the OTA firmware update”. If someone could report back on that it would be great.

No critical fixes in this release but a bunch of small and (hopefully) good fixes.

For the device code:

  • @mc-hamster minor range test bug fix
  • @mc-hamster add support for tlora_v1_3 boards
  • @vfurman added rssi indications for incoming packets
  • @timgunter added choice to use an alternate python interpreter in our install scripts
  • move gps_rx_pin for tlora v2.1 from 36 to 15
  • fixup channels after factory reset
  • fix firmware OTA update while is_router (NOTE: this change will not help until FUTURE releases)
  • do not hang if fromradio queue is full

Android changes:

  • @danielnemenyi fixed a busted documentation link
  • @vfurman added rssi display
  • Add a ‘reset to defaults’ radio channel buton
  • Fix a bunch of rare autobugs based on analytics reports

Device release here:

Android release here (for those that can’t access google play):

1 Like

New default channel button in Android app

1 Like

Couple of things hopefully just me. Tbeam 1.2 on 1.2.11 node not router.

  1. I didn’t want to wait for the play store so I downloaded the apk and it would not install over the existing 1.2.11 play store version. Simple error stating that it did not install. Yes, chrome has permissions to install\sideload.
  2. I wiped the app cache and data and uninstalled. Then the downloaded apk installed.
  3. Region became unset, is that an app setting and a result from clearing app data?
  4. Channel was blank and some garbled text is displayed at the bottom. Restarting app and re-plugging usb got channel and qr back.
  5. No prompt to update firmware via usb. Prompt to update came but only via bluetooth and only after re-pair, reset song and dance.

1 Like

ooh thanks for the quick report, I’ll try to repro and spit out a quick 1.2.14 of the android app. (I’m deleting that apk to prevent confusion)

2 Likes

I upgraded the android app from 1.1.50. I connected to my M8N Tbeam (I guess my normal TBeams were sleeping). It said it needed to update firmware. I noticed that the region wasn’t set and tried to press on it with my finger, and the app disappeared (I assume it died). I started the app again and the region had been set to US. They seem to be using the channel #LongSlow-V now. I only have one android device signed up for alpha testing, so I couldn’t really test phone to phone. I could connect to 1 tbeam and send a message and then connect to another tbeam and receive the message, and hear the message receive sound from the phone. That didn’t necessarily happen every time. Maybe a timing thing around when I switched which tbeam my phone was connected to. I sent the message test5 and I saw test upside-down-question-mark on the LCD screens. I looked down at my phone and saw test to the power of 5. I tried test5 again and it worked. I still have 1.1.50 tbeams that could still be flooding the air with lora messages.

1 Like

ok 1.2.14 of the android app is up now to fix problem @Havealoha noticed. That problem would only affect ‘from scratch’ installs and it was super good to find, because new users (by definition) are doing from-scratch installs.

btw: if you go from play store version to github version you will need to uninstall first, because they are signed using different keys.

thanks @DylanHoen, the problem havaloha noticed could also cause the same crash you noticed.

I tried to upgrade to 1.2.14, but there was no upgrade button on the play store. I checked my current version and it was 1.2.11? I had just updated it an hour ago. Maybe I should reboot the phone.

alas, the play store usually takes a few hours for their semi-automated review to ‘bless and release’ after I press the button. So probably try tomorrow?

When I get to the advanced settings in the android app (1.2.11) I can enter a number in the gps broadcast seconds, and then click on the sleep enter a number in there and press Done, and only the second number is accepted, and the first one goes back to what it was before. I guess it is garbage in, garbage out, but it was not intuitive.

1 Like

The firmware update 2.1.13 went smoothly via the app on both the t-beam and the Lora V 2.1. I don’t get a GPS signal from the smartphone on the Lora V 2.1. When I switch off the GPS, I get a pop-up window with a message to switch on the GPS. However, when I do so, I get no GPS signal and it is not shown on the map. Writing texts works. T beams GPS works fine, also showing in the map.
When I turn off the Lora v 2.1 and turn it on again, I have to reconnect the device each time with the 6-digit PIN via Bluetooth. In firmware 2.1.11 GPS worked fine.

@hansi hmm - on your lora v2.1 did you add a hardwired GPS or are you talking about how the phone normally “fills in” if the local device doesn’t have a GPS and now it is not?

I am talking about the phone normally fills in

2 Likes

I see this too. To get the value in the first field to stick you must press enter before moving focus away. Device name field behaves similarly, not intuitive. On the channel tab you have a lock button to affirm\apply final settings, maybe it should be an apply button and the same for the device tab and the advanced settings panel.

I like the idea of a big purple apply button. It could be grey by default and then it turns purple when changes to any form on any tab is detected, including replacing the lock icon. Maybe move channel reset, report bug and stats checkbox into advanced settings menu.

1 Like

thanks @hansi I reproed what you described (phone not filling in for ‘missing’ local GPS). I’ve fixed it in the android app. In the next day or two I’ll put out an android app with a fix. I’ll also have the android app provide locations any time the local device failed to do so (so that units that DO have GPSes but crummy GPS signal will get the same assistance). Unless location_sharing in the meshtastic device is set to disabled.

The device-install.sh script for 1.2.13 is throwing an error - I had to revert to using the script from 1.2.11:

If you have Python 3 installed, you could edit the script by changing
PYTHON=${PYTHON:-python}
to
PYTHON=${PYTHON:-python3}

2 Likes

Ah, I didn’t even think to check github for any mention of the issue… You are absolutely correct - changing ‘python’ to ‘python3’ fixed it in my Ubuntu VM. Thanks!

1 Like

The new device install/update assume python is in your path as python – not python3. There are a few things you can do:

  1. Add -P python3 (assuming python3 is in your path)
  2. Add -P /path/to/python (if python is not in your path)
  3. Modify your path variable: export PATH="$PATH:/path/to/dir/containing_python"; ./device-install.sh ...

It just occurred to me that my tloras now appear to go sleeping after a while. I’ll need to check the power consumption improvement, but that’s really good news!

1 Like