Meshtastic

New android alpha release 1.2.50 ready for testing!

Hi ya’ll,

Sorry I’ve been away @mc-hamster pinged me to remind me that the android build has some good fixes contributed by @AndreK and @srichs. So I’m back (briefly - alas back still crummy but getting better I think) to do an official build.

It seems to work great for me, but can someone else try this APK and confirm it works for you? If it does, post here and I’ll bless it so it can go up on the amazon appstore as the new std release…

6 Likes

I found that I had to remove the previous version first prior to installation.
So far it hasn’t crashed. :slight_smile: No smoke from my phone so… so far so good!

Installed no problem on top of previous version while still running.

T-beam wireless update works, Heltec board wireless update didnt work.

Pixel 4a, Pixel 5a.

Got it on three devices, seems to work.

Yay! Thanks all - I just pushed it to the amazon appstore. They should have this new version starting tomorrow. In the next few days I’ll work with @mc-hamster (and possibly @AndreK) on the annoying things we need to get reblessed on the google appstore (mostly making a youtube video and document explaining to them why we need optional location permissions)

2 Likes

I didn’t uninstall first. App works.
Used it to update a T-beam. that works.
Tried to send a message… screen on T-beam never shows new message.

UI renders correctly and functionality seems to be intact. I turned on the debugger in the android SDK and didn’t see any exceptions being thrown except for the following which is thrown once upon init’ing the app:

com.geeksville.mesh.service.RadioNotConnectedException

I’m assuming that it happens when the app is bootstrapping the connection to the device.

Messages are being written and read to and from the connected device. The settings, channels and mapbox view worked fine.

Hardware:

  1. Google Pixel 3a (GrapheneOS Android 12)
  2. TTGO Lora32 v1 (meshtastic 1.2.46)

I hope this helps.

Already was mentioned, just want to confirm: after sending a message I don’t see it anymore on the device’s display. Firmware: 1.2.46

Also, I have connected USB to android<>device. I see USB in Meshtastic’s Android device list as “/dev/bus/usb/001/003” but when I choose it keeps showing “Not connected, select radio below”. When I choose Bluetooth device then it works as expected.

Meshtastic over USB on Android isn’t supported (yet), AFAIK. Someone else was tinkering with that a while back…