Meshtastic

Having an issue (new to this)

I received my two boards yesterday along with the screens. Got them attached and the device boots up with a protocol window with an ID for both boards. However it does not show up in meshtastic or in the flasher software when connecting it via USB. My main phone is a Galaxy S10+, thou I have tried a cheap smart phone I have for a hotspot, and my old Galaxy S7. Anyone have an idea what could be going on? I have done the listed stuff about force stopping, clearing the app data, re installing the app, as well as the above of trying many different devices.

For the flasher software I read up on that a bit and figured as the guide stated the drivers needed installed so I did that but sadly nothing shows up in the drop down at all. I wanted to see if maybe the device just needs the code added or updated which is why I tried the flasher

Normally I like to figure this stuff out on my own but with never dealing with a mesh system like this I am at a loss. I’ve spent most of last night and today looking over stuff online and re doing some test. However nothing seems to be pushing my progress forward to fixing this. Sorry if this has been answered in a different post. I tried looking before posting but could not find a solution or anything fully related to this.

Hi and welcome @StealthyMartian!

So you want to flash/update your devices because you’re not able to connect with non of your android devices.

What OS are you using?
If you are using windows 10, what driver did you install?

Did you try another USB cable and/or USB port?
You also could try rebooting your PC.

Thank you for the reply. I am indeed using windows 10 and for the drivers I used the x64 from this website. https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers which was listed on the github https://github.com/meshtastic/Meshtastic-device#installing-from-a-gui---windows-and-mac

I was wanting to try and see about updating them just to make sure they were on the correct build. Since they are not showing up anywhere on the devices.

For the USB ports I have tried all that is on my computer with the same results along with different cables. I have also rebooted my computer a couple times as well.

Hmm, strange behavior…
Another guess: Does the device show up properly in the win10 device manager? If so, maybe it’s worth to try installing the driver manually there.

1 Like

Okay so I grabbed a 3rd USB cable and it now shows up in the flasher (looks like i need to order new cables). However I get this error now for both.

Using ‘COM4’ as serial port.
Connecting…__
Detecting chip type… ESP32
Connecting…

Chip Info:

  • Chip Family: ESP32
  • Chip Model: ESP32D0WDQ6 (revision 1)
  • Number of Cores: 2
  • Max CPU Frequency: 240MHz
  • Has Bluetooth: YES
  • Has Embedded Flash: NO
  • Has Factory-Calibrated ADC: YES
  • MAC Address: XXXXXXXXXXXXXXXXXX
    Uploading stub…
    Running stub…
    Stub running…
    Changing baud rate to 460800
    Changed.
  • Flash Size: 4MB
    Unexpected error: The firmware binary is invalid (magic byte=50, should be E9)
1 Like

Nice! :wink:

Ok, what exactly file are you using and what boards do you have?

1 Like

For the firmware I am using the latest release 1.1.0. Should I do the 1.0.0? and for the board I am using the following 923Mhz OLED: https://www.aliexpress.com/item/4001220665769.html?spm=a2g0s.9042311.0.0.66a44c4dWLJkbk

923MHz is the frequency for Hong Kong and India I think, is this correct? Ther isn’t an firmware build available right now.
Someone requested a version for HK some days ago. Maybe there are some other regulations in your country, that needs to be considered …

Anyway, did you flash the .zip file or did you extract the files? There are firmware files for every country supported right now.
Just for testing you could flash the US version, which is 915MHz and will probably work on your hardware… this is probably the version it was shipped with :wink:

Thanks I will give a few things a try and see what I can figure out.

You’re welcome, good luck :wink:

Ah and feel free to open an issue on github, to request a build for your location!