Noob is lost, plz halp

So I decided to take the plunge and try my hand at flashing non-meshtastic lilygo boards. Haven’t done anything like this since rooting phones in 2010…Aaaaaaaand I’m lost.
Went to the Meshtastic site, followed directions, downloaded Py, homeflasher, and Silabs.
no serial port found

Help me Obi-Wan Kenobi; you’re my only hope. :-/


1 Like

Also, have 1 lilygo that came flashed with Meshtastic but it isn’t “seeing” any GPS satellites. Funny story (maybe): the Meshtastic Tbeam pairs okay with my phone but has no GPS and the red and blue LEDs short-flash in tandem while the non-flashed board has red LED constant-on and the blue LED 1-second flashes.
Is there maybe a page or thread with “lay-person” information?


tbeams first gps lock can take quite some time (sometimes hours) with the stock antenna. just take it outside.

what directions are you following? try this:

Sooooooo out of my wheelhouse.
And I thought I was doing great when I got the OLED soldered.

I used to consider myself a rather intelligent person.
Obviously, I’ve been VERY wrong in that opinion.

1 Like

follow this: GitHub - meshtastic/Meshtastic-gui-installer: Cross platform, easy to use GUI for installing Meshtastic firmware. (aka m-flasher or meshtastic-flasher)

or download the standalone installer for windows (meshtastic-flasher-win.exe) here: Releases · meshtastic/Meshtastic-gui-installer · GitHub

Yeah. Tried that. the meshtastic flasher doesn’t detect the device, it is running “SOFT RF”, so I tried using Py but no luck there either.
The good news is that my Tbeam that already had Meshtastic is picking up GPS sat’s now.
So… there’s that.

“Invalid syntax” seems to be the only response I get in Py 3.10. Obviously I don’t speak programmer or I would get something different. …
Wish I knew someone local who could come in to my office and help.

Fun fact:
a vape charging cable will not work as a data cable.
Yes… I’m a moron.
Using the proper cable, it works like a champ.
Thanks for trying to help.

1 Like

1 Laaaaaast question:
any ideas why the screen brightness would be constantly scrolling across the OLED?
Aside from a bad micro switch; It wasn’t doing that until the flash. Tried re-flashing and got the same thing. Maybe a NC/NO conflict in the code? Looks like it flashed to and my other unit is on 1.2.52…Oh … Wait 1 …
So I re-flashed to 1.2.52.b63802c and … nope. It’s gotta be a bad micro switch, I guess.
Sunufa… GAH!

When it asks if the device is running meshtastic 1.2 or greater you need to say no.

Actually, Noob ignorance strikes again.
Under “Device” … Yeah. Can’t flash T beam LORA firmware to a Tbeam.
sigh I’m learning. Slowly, but I’m learning. SMH :wink:

Okay, SERIOUSLY the last issue I (should) need help with.
Got both units up and running, 1 Tbeam for my tablet, 1 Tbeam for my phone. Setup my mesh network. Send texts FROM tablet TO phone = fast and smooth.
Trying to send texts FROM phone TO tablet, though … none go through.

What operating system are the phone and tablet? Have you checked the channel url with meshtastic --info on the command line interface?

Weak power supply sometimes.

1 Like

Well, they’re both on the same channel.
I plugged them both into the PC, opened the Meshtastic flash app, copied the settings, compared and they’re identical.
Both devices are android. 1 a galaxy tablet and 2 a galaxy phone (1 year old each).
Brand new 18650 batteries, fresh off the charger and Tbeams show full battery charge.
Both Tbeams are “seeing” each other as well based on GPS information and the fact that they’re working from the tablet to the phone.
Really not sure why I’m only getting 1-way comms. but I worked on them for several hours last night and still got nothing.

And there it is.
Did you know:
if you “turn off” all of your “trust certificates”, your phone becomes more of a paperweight than a communications device?
I didn’t. Now I do.

The More You Know …

1 Like