Meshtastic

1.2.16 alpha of device, android and python lib/tool is out!

Thanks to your alpha testing and the numerous developers who contributed to this release!

Major changes in the device code:

  • @mc-hamster improved store and forware plugin
  • @IZ1IVA pointed out that we weren’t storing altitudes in the node db
  • @IZ1IVA fixed python tool usage in our install scripts
  • @mc-hamster added a reboot counter to MyNodeInfo
  • move streamapi into a thread - which fixes loss of comms for the command line tool (or anything talking over USB)
  • phoneapi now cleanly shuts down bluetooth while talking USB
  • add last_heard to nodedb records, to track the last time we heard from this node (as distinct from position.time)
  • add a reboot message to adminproto

Major changes in the android app (on play store beta channel):

  • @anothercarolina improved the Spanish translations!
  • @slavino improved the Slovak translations
  • Fixed the position fill problem noticed by @hansi
  • We now ‘fill in’ providing GPS for local nodes that don’t currently have GPS signal (even if they have a GPS chip - they might not have signal)

Major changes in the python tool:

  • @isinglass Changed nodes table to use a popular/supported library
  • We now support --reboot to reboot a node (even if remote)
  • Added enum and field reflection
5 Likes

I believe it was @iz1kga :wink:

2 Likes

Update ota worked fine. Advanced settings still requires enter before moving focus. OTA update still not offered when connected via USB vs BLE.

Yay! Meshtastic --qr works now and I see you updated the --help set is_router! Thank you, you can ignore my two issues

I assume the checkmark inside the cloud icon signifies that the uploaded message was received by another node. In a channel with only one node, sometimes a message shows a slash and sometimes a check mark. How could the message have been received when there is only one node?

2 Likes

I got a Permission Denied error when I tried to update tbeam firmware over USB from windows 10 64. Did the syntax change?
Also, I noticed files that I didn’t pay attention to before: spiffs-1.2.16.bin and system-info.bin. Are they supposed to be loaded, too?

Checkmark means the app is connected to the node.
Arrow means it connected but the node is in sleep mode.
Slash means it is not connect to the node.

So how do I interpret these icons?

Hi @Havealoha,

Those first two mean the message was sent but we never got an ack back (from anyone) which makes sense if there is only one node powered (the one connected to the phone).

The next two are troubling. Are you absolutely sure there was no other node powered (i.e. not even sleeping with its display off)? Is this similar to what you noticed @luxonn? (I’m having a hard time reproducing but will try more today)

The previous screenshot was a channel with a few nodes miles out of range and likely off. This screenshot is a new channel with a new node and this device is the only node.

1 Like

ok thanks! will keep trying.

oh i see - fixing. oops typo

Attn: Anyone who hasn’t downloaded this yet. Don’t bother. It is basically fine, but I’m pushing out 1.2.17 to fix the (serious) problem that @luxonn and @Havealoha reported. It has been there for a while.

1 Like