Meshtastic

Device and android apps 1.2.11 ready for alpha testers!

Release notes for the device code:

  • GPIO, serial and external notification plugins are now “locked down” and require that you assign a special “gpio” channel before you can use them - this is because these extensions allow users to whack hardware and we don’t want to let random strangers do that to nodes. I’ll be making another post this weekend with a new user manual entry on how to create and distribute these channels.
  • Admin operations for remote settings and channel changes are now supported, I’ll be documenting this in a similar user manual entry
  • Fix the hop limit for android messages - so that they properly route through N nodes as needed
  • cleanup how hardware model information is used this makes things cleaner for app writers (thanks @sachaw)
  • Fix the flash-update script so it properly always runs the new load
  • Fix heap corruption due to a bug in the TinyGPS library

Release notes for the android app (available in the play store testing channel and as an APK):

  • @goga added a very nice coordinate and time display for nodes
  • @vfurman added a tool to dump messages in CSV and fixed position broadcasts where the phone is helping
  • Fix channel URL sharing for all channel formats
  • Fix the channel suffix letter so we use the same algorithm as the device code
  • Allow the 1.2.x apps to update 1.0 firmware OTA (previously they only supported >=1.1 firmware)
  • Fix a few autobugs reported by analytics
  • include device 1.2.11 firmware - see device release notes for info

Full list of android changes:

6 Likes

On tbeam t22 v1.1 Update from 1.2.10 router mode to 1.2.11 fails. Lcd initially shows “updating” and app shows progress then screen blanks and app disconnects. Waking up device with middle button shows still updating but app reconnects and prompts to update. App then reports firmware update already in progress when attempting again. Force close app and reset device to continue. If try to keep device awake by pressing middle button every 30s, app will report update failed. Will try non router nodes soon. Other non router node updated fine.

Pressing the middle button a little more frequently and keeping the devices closer together got it updated. Maybe when is-router, the power save interrupts the update?

1 Like

Thanks!
I am testing it now. OTA updates from 1.2.10 went well.
So far so good.
The time display for nodes is super useful.

1 Like

Good theory. Thanks for the report!

1 Like

I’ll jump in here with pull requests at some point when I get more confident with understanding the code. Looks like it’s SDS?
Maybe an if bluetooth update process statement here? Meshtastic-device/PowerFSM.cpp at 5cc3ff16a3bbe05b79e84bc9de3601e1c39ec9ea · meshtastic/Meshtastic-device · GitHub
Or setPref_sds_secs to 600 when an app update starts?
Or an entirely new pref set just to signify an update is in process and not to sleep at all here Meshtastic-device/PowerFSM.cpp at 5cc3ff16a3bbe05b79e84bc9de3601e1c39ec9ea · meshtastic/Meshtastic-device · GitHub

1 Like

Two TLora OTA firmware upgrades worked, one retained previous settings and the other appears to have totally reset.

On to the tbeams!

I can second this, two Tbeam router nodes failed to update with the OTA update, disconnected in app and screen turned off on device. My one non router tbeam updated fine.

1 Like

meshtastic --dest 050c17c4 --set-owner CF3

Returns an error that NodeID 050c17c4 not found in DB

What is it looking for in the DEST variable?

1.2.11 device and 1.2.12 python

Thanks

Updated both tbeams ota first try. Just a minor thing - I noticed that the update button becomes pressable after the update finishes but before the tbeam has finished rebooting post update, and you can press it again and it looks like it tries to update again, but then the tbeam finishes rebooting and everything is fine. It should probably stay disabled until reconnection and the version is checked again.

1 Like

@Chiumanfu maybe this helps?
The destination node id for any sent commands, if not set ‘^all’ or ‘^local’ is assumed as appropriate

setting owner names (or any other settings) remotely via the mesh is not yet officially supported. I’ll be posting a thread today asking for (one) alpha tester to be the first person to try it. So check out that thread once I write the docs.

But in answer to your question, use the node ID as listed by “mesthastic --info”

it would be something like (note the need to escape ! in most shells)

meshtastic --set-owner myname --dest \!050c17c4
1 Like

Using app 1.2.11 I was able to connect to and update a two devices from 1.2.10 to 1.2.11 OTA (not tried 12 yet. I did the first update to 1.2.10 over serial port. However the router device that is still on 1.50 seems to pair OK, but then does not get any further. It seems to stop with “Not connected, select radio below”.

I will update it via Python to 1.2.x, and try again. Andy

1 Like

I have just tried the latest firmware 1.2.11 I have flashed it on a Lora v1 and a Lora V2. I installed Lora v1 with the ESP flasher, but first I had to flash firmware 1.1.50 and then I could upgrade to the latest one. I upgraded Lora V 2 via Bluetooth. Everything went without a hitch. However, there was a problem sending a text in the chat. I can send texts from Lora v1 to Lora V2 without any problems. However, it does not work from Lora V2 to Lora V1. I get a tick in the chat but the message does not arrive at Lora V1. It is neither shown in the OLED display nor in the app.

Also, I cannot see the PLI of Lora V2 on the map from Lora V1. In the app With the Lora V2, however, I can see Lora V1.

1 Like

The device worked correctly after a serial update to 1.2.12 - but the OTA update did not work from Android 1.2.11.

1 Like

hmm - do you remember what firmware version you were OTA upgrading from?

It would have been 1.50 (almost certain). I left it for a while and restarted the app (after it had initially paired), but it never suggested an upgrade. It also never showed any message about firmware versions, so I guess it never really connected fully.

If you need someone to test, I could downgrade to 1.50, and re-try it?

1 Like