Meshtastic

You must set a region!: Error Screen (Android 9 LG L322DL TracPhone)

Hello,

I am trying to set up the suggested TTGO boards with a lowcost LG TracPhone (no sim card). Ideally I would like to not need a sim card if at all possible. When trying to connect to the boards, I receive the following error message on the gear icon screen:

“”"
You must set a region!

• None (disable)
You haven’t yet paired a Meshtastic compatible radio with this phone. Please pair a device and set your username.

This open-source application is in development, if you find problems please post on our forum…
“”"

I looked through the github but didn’t find anything that helped me fix my problem. I am still unfamiliar with the boards and have had trouble finding documentation to debug, so I am posting here with the hope someone can point me in the right direction.

Any help is appreciated.

2 Likes

Hi @jaquielajoie welcome to the meshtastic community I hope your stay here is a pleasant one :slight_smile:

What frequency does your ttgo board use? is it 433, 915, 868?
The region is the frequency you are allowed to use in the country you are in.

Maybe the app should ask the country where it is located and also the region, in case the person doesn’t know which is the free frequency :thinking:.

Here is a guide to the app

And here is the list of allowed frequencies by country

1 Like

Hi! Thanks for the reply:)

I’m in the USA, I Believe I purchased the 915 boards, but the chip on the front says
“”"
TTGO
868/915 Mhz
Modle: Lora32
“”""

1 Like

Then you must select region US 915 :slight_smile:

It is a board that works with both frequencies, remember to turn on the radios always with the antennas connected.

2 Likes

Okay - I’m guessing the selection happens on the device (made easier by the oled)

For some reason after soldering the oled on the screen is unresponsive (I double checked that solder isn’t touching extra pins and that the correct pins are being used).

Should I re-flash the chips?

I have 3 lights appearing: one blue light underneath the oled, one red light underneath the oled, and then a red flashing light near the reset button. I haven’t found an online description as to what these indicate. Do any of these indicate some other type of error?

Before it was like this, the firmware defined the region, now with the app or the python client it is defined

Did you use a compatible display?

Regarding the lights I have no idea, but maybe you can post the information sent by the device through the serial output :thinking:

You can also send a picture of the ttgo board :thinking:

1 Like

No need to reflash. Just install and run the android app (or python app - though that’s a command line app and perhaps less friendly). Connect to device with the app and it will prompt you to set the region (on the upper right of the settings tab on the app).

I will be adding a dedicated toggle for this in the desktop meshtastic-pygui so you can set the region by simply choosing a checkbox

2 Likes

I am also experiencing this issue on a Pixel 5 (Android 11) and a Pixel 5X (Android 8.1.0). I have a TTGO T-Beam V1.1 (with no screen) running 1.2.28.

After successfully pairing the T-Beam using the pin revealed in the serial terminal, I open the Meshtastic app and go to the settings tab. The text says “You must set a region!”. Under that, there it has radio buttons with two options “None (disable)” and “Meshtastic_3c88”. Selecting either of these, “You must set a region” changes to “Please pair your device in Android Settings”.

Update: After frustratingly mashing the radio buttons, it allowed me to set the region.
Update 2: After selecting Meshtastic_3c88 radio button, I have to wait patiently (not my strong suit) until the “Your Name” and Region options appear.

I’m also having this issue with 2 of my devices, a Sony Xperia X running Android 8.0 and my LG Tab running Android 7.0. My OP6 running 10 seems to work fine.


For the first two phones, this is because they haven’t connected properly to the nodes, the cloud symbol is the upper right still has a cross through it showing that the app is still trying to connect. Once it has connected it should give you the option. Sometimes you need to go into the paired Bluetooth devices setting and remove the device before trying to add it again through meshtastic. This is a known problem with Android.

Yeah, this has been a problem since I started experimenting with these again. Last time i was these all worked just fine, that was about 3-4 months ago. They are paired in the android settings, some times it flips from “You must set a region” to “Pair your device in Android settings”, or something along those lines.

If you use the Meshtastic-PyGUI app then you can set the option for region to 1 the GUI for your radios without pairing them to a phone.