Web Interface issue

Heltec ESP32 V2
Latest firmware
Latest web files

Devices are communicating perfectly via the app and appears to have no issues other than the web interface. So I am able to to access the Metastatic interface no problem but only a few things seem to function. I can’t view/send messages,user list shows no one,device settings just goes to a blank page,packet log shows null,device file system works,and connect to wifi leads to a blank page. Sorry in advance if this seems trivial but I am new to this.

The web interface was written for the firmware versions up to 1.1.50. There was a big change to the way the firmware works when it moved to the 1.2.x branch which stopped the web interface working. @sachaw is currently working on a new version of the web interface which I believe will be moved onto the Meshtastic repository when it’s ready. His work in progress can be found at GitHub - sachaw/meshtastic-client.


Yeah, should be quite soon, had some interest from some other Devs, a few key issues that we need to work through still.


Got ya, couldn’t figure out what I was doing wrong and I didn’t know about the 1.2x + web interface issue. Thanks

I’m trying to connect to a heltec v2 on 1.2.64 which is connect to my WAN. Sometimes when I enter the address of in my Chrome browser I can get a meshtastic logo to load in the address window. I’ve never been able to get further than that.
It times out the browser.
The device appears on my list of devices connected to the network.
I think from the question it’s clear that I’m no computer wiz. But I did spend several hours yesterday figuring out how to use the CLI to change the settings on the heltec device.
I have some t beams on the way from China but wanted to get this heltec set up as a solar powered router at some high ground before they arrive.

Try flashing the latest 1.3 alpha with the new webUI

I have issues with the web interface client.meshtastic.org and have no idea why :confused:
I flashed the 1.3.40 firmware on the device but nether in edge nor in chromium or chrome it is possible to connect via serial or Bluetooth. It worked on 1.2.65 but not with a 1.3.x.
I saw there are web releases as well, is “client.meshtastic.org” always the last version or do I have to change there something as well? btw. android connection is running perfect.
Thank you :slight_smile:


Nobody an idea? It’s the same for T-echo and T-beam. I can find the device but cannot connect.
Is there a way to read out debug info in this case? Maybe this could help.

1 Like

I am struggling for weeks now with this connection, any hint?
Every driver is up to date, tried different browsers and devices (T-Beam and T-Echo), changed serial baut rate, flashed the last 1.3.41 firmware (CLI and flasher .exe) but it won’t work. CLI interface is working via cmd window. When I read out the chip id i get this:
C:\WINDOWS\system32>esptool.py chip_id
esptool.py v4.2.1
Found 3 serial ports
Serial port COM6
Detecting chip type… Unsupported detection protocol, switching and trying again…
Detecting chip type… ESP32
Chip is ESP32-D0WDQ6-V3 (revision 3)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
Crystal is 40MHz
MAC: xxx
Uploading stub…
Running stub…
Stub running…
Warning: ESP32 has no Chip ID. Reading MAC instead.
MAC: xxx
Hard resetting via RTS pin…

Don’t know if it looks like as it should.
But I noticed when I try to connect via browser serial and it is not working and I press the retry button [see two pictures above] for about 100 times the connection seems to happen very slowly but is not stable because it needed more then 100 tries and is just unusable.
Where could I search for a solution?
Pleaseee it is really frustrating :confused:

The hardware btw is also new (Surface Go 2).
Thanks :slight_smile:

Works now with the new hosted web release.

1 Like

you wrote:
Works now with the new hosted web release.

Where do I find the right information,?

I just went to the hosted site" client.meshtastic.org/", it should always be the updated one. Important is to clear the cash of the website in your browser, otherwise it loads an old version.
There should also be a version hosted at the device, but I think this is still in work and not available.

all 1.3.42 and newer firmware builds again contain a working web interface for ESP32 devices. nRF52 devices can e used with a hosted or locally deployed version.