Meshtastic

Heltec Wifi Lora 32 only working via command line

I have some experience with Arduino devices, but I’m brand new to meshtastic, ESP 32 and LoRa, so I thought I would grab a few Heltec units off Amazon locally (ordered TBEAM from China) and give them a try. I flashed the unit with the windows gui tool and the latest binary (1.2.30.80e4bc6), and tried using the iOS app via TestFlight - it would connect over bluetooth but nothing in the app would work like settings or messages.

I figured it might have been the app, so I decided to get it connected to wifi and use the web interface, so I ended up installing python on my windows machine (for setting wifi) and then doing the manual esptool.py actions to erase and re-flash the unit with the correct partition setup for the web server, and then uploading the files to /static but that resulted in the same mostly unresponsive interface, both the settings pages would render blank and had to be refreshed to get back, but the Device Status page seems to be working, and the Packet Log page only partially - packets appear with null data.

The only way I have been able to get any message sent between the units is with the python meshtastic command line tool, and it only shows up on the unit’s screen - I can’t get the app or the web page to display messages.

I’m not sure if it’s related but I can’t seem to get meshtastic python to connect to the IP address of either unit, I have to have them plugged in to USB serial and tell it to connect on the COM port that way.

I feel like I may have missed a critical setting or there’s a version mismatch, or something like that so that - I can’t seem to locate any information on this particular glitch.

Welcome to Meshtastic! Hope you enjoy it! You’re not alone in limited use of the devices. I’m an iOS/Mac user and the android app is much further along in development. I’ve used serial connections, the upcoming meshtastic-client by @sachaw and the CLI tool primarily in using my devices. There’s also the Meshtastic-PyGUI being developed by @zebus.

I believe the TestFlight iOS app is currently only supporting firmware 1.1.50.

If you were using the --host argument, there was a recent device side bug that is fixed in the newest alpha release

I hope this is helpful in the slightest! Let us know anything that’s under documented on meshtastic.org. It’s a work in progress and feedback helps a lot!

1 Like

I see this behavior also on the T-Beam – web version 0.1.7, device firmware version 1.2.38.cf4e508.

I will try installing the older version of the firmware and see how it does with the iOS device. It did feel like it was a version mismatch kind of issue.

I noticed the web interface says “Requires radio firmware 1.48 or higher (preferably f6e2695a4d095020a7962e1048b1d29fe9480e5e or later)” which doesn’t seem to relate to the latest firmware binary version, at least it’s not close and possibly has the same limitations as the iOS app does?

I did follow the instructions for installing Meshtastic-PyGUI but it didn’t work and there didn’t appear to be a lot of success in the thread, so I didn’t try much else to get it working.

One thing I felt like I couldn’t locate which would help a newbie that is stuck with the command line is a step by step guide to properly set up a factory fresh unit, mostly for what settings need to be set and their commands - to get a LoRa meshtastic network set up, such as channels, owner, region, encryption, etc… I have most likely overlooked it but I kept seeing reference to using the android app, which unfortunately won’t work with the old v4 samsung tablets I have around.

It’s been a minute since I messed with the web interface other than the one @sachaw is making so I can’t remember details. I’ll take a look.

My fork on GitHub of the Meshtastic branch has a settings section with CLI commands for most common use cases. I’m still working on it but you’re welcome to check it out I’m hoping to submit the PR later this week, so any comments you have on it, let me know.

I plan on consolidating the Meshtatsic-web repo and my client this week, still trying to work out how I want to do things, but is working quite well with 1.2x devices

3 Likes

I installed firmware 1.1.50 and that appears to have corrected both issues, the iOS app and the web interface are working as expected. The command line not so much now (says it need 1.2 at least), but I can work with this now to proceed with testing the devices for application suitability at least.

@sachaw I looked at the github for your client, but I did not understand how to proceed to use it, I am probably missing some foundational knowledge.

Right now, the old Web UI and the IOS app are 1.1.x compatible, the python library and new web client are 1.2.x compatible, if you don’t know how to build the code in my repo give me another couple of days and I should have automatic builds done.

2 Likes

I’ve played around a little with the 1.1.x firmware and the web interface /iOS app: it’s somewhat functional but not very useable, so I would like to know what the steps and requirements are to get the 1.2.x compatible web client working until I get a compatible Android device. I’ve got a headless RPi3 running Octoprint that I can SSH into if the process requires a Linux system of some sort and I can follow instructions reasonably well but I’m not too familiar with building code / compiling, so I need to be able to read fairly specific instruction for stuff like that.

1 Like

I finally got a chance to try out the HELTEC devices with the 1.2 firmware, some TBEAMs and the Android app with my fellow mesh makers - they were functional but seemed to reboot for no reason, especially when sending or receiving a message. I had previously only seen this behaviour when I tried sending a very long message when I had the 1.1.50 firmware installed. They don’t reboot randomly when I test them at home with just 3 units but adding another 3 close by seemed to change how they acted.

I was also pretty shocked that the Android app seems to have no device settings to speak of, especially when compared to what’s on offer as settings in the iOS app and the old web interface - not that I understand all the settings, but it seems like stuff that you would want to adjust. I am going to try updating firmware on a Samsung Galaxy Tab 2 tablet to allow me to install the apk, but I am still interested in testing out the new web interface - I’ve designated an older laptop with good amount of ram and ssd as a linux machine, just trying to choose a distro and then I should have some proper tools for working with this stuff.

Well, it took all day, but I got Android 6 on the old Tab 2 and the Meshtastic Amazon app is installed and working. Tablet is running a lot faster now too, go figure.

The rebooting problem I was experiencing away from home appears to have been related to having the wifi ssid and key set so it was trying and failing to connect. Re-flashing to default settings or turning soft AP mode on solved that problem.

Now weird problem with one Heltec popped up that I’m trying to solve, I turned it off before going to bed by holding the top button down and tapping the bottom button. It was fully charged but unplugged, and set to run as a range test sender, but when I turned it on in the morning it was dead, so I plugged it in and it booted to totally factory fresh, unset region, etc. I tried changing preferences with the command line and they’re fine until it reboots and then it’s back to factory fresh again. I tried doing a full re-flash of 1.2.39 in windows with the .bat file but it’s still behaving the same. I noticed some older firmware had this kind of issue pop up and the solution was to flash less current firmware temporarily to get it working again, so I’ll give that a try.

I wonder why it happened? If the battery failed when it was “off” would that cause the unit to malfunction like this? And why? I noticed that a low battery is not handled properly when it’s on, it just starts rebooting, so that could be the source of the problem?

Is there a walkthrough on how to get the web interface working?

A few of the people I am working with only have iOS devices, so the web browser solution would be best. :slight_smile:

Those are v1.1 firmware. The v1.2 firmware web interface doesn’t work yet, at least, I have not been able to get it to work.

Pre-requisite: You have Meshtastic Device firmware between version 1.0.32 - 1.1.50. A client for version 1.2.x will be released shortly and the documentation will be updated accordingly.

The 1.2x web interface is working fine right now, it is currently located at https://GitHub.com/sachaw/Meshtatsic-client
I plan to have builds available for people to use in the not too distant future, this repo will soon replace the existing web one once it’s generally available. If people want to test it out, feel free to dm me on slack and I can help you get it to work

1 Like