No sats. No GPS lock. Tried a few different things already

I currently have two 1.1v neo-6m tbeams. I’ve tried a few different firmware versions ( and1.2.46) but am now using 1.2.47 and am still not getting any gps. Leaving them outside isn’t helping either. It just continuously says no sats and no gps lock. Any advice on what do to next? I read some threads regarding checking the connection of the ceramic antenna and it appears to be connected fine, I also tried the trick to short out the gps battery and that did not change anything either.

1 Like

I had one faulty GPS antenna connection on my TBEAM with NEO-8MN and the same no-lock behaviour, no matter inside or outside. The onboard connector probably was contaminated from the manufacturing process. Unplugging and replugging the antenna a few times did the trick.

1 Like

Thanks, I played with them a little more and finally got them both to show GPS after left them outside for 2 hours. They had GPS then but havn’t got it back since. So I know it works now at least, albeit not well. A friend has two devices and his are constantly showing GPS location.

I just purchased a Tbeam and loaded Meshtastic on it and have similar issues with the error “no GPS lock”. Have your issues resolved themselves?

1 Like

@mc-hamster @geeksville

These are the cases which motivated me to file a very important feature request: the ability for the phone’s location to be supplied to the board and used if available, even if there’s on-board GPS.

Phone location should be given first priority.

I’ve explained the reasons in my feature request.

It’s up to the phone to decide if phone location is to be published. There are also privacy considerations that we must adhere and the phone would be the best to decide that, along with proper notification and confirmation.

Of course. It should not be enabled by default.

I’m just saying that it should be a toggle. As of now, enabling the “supply location to mesh” toggle does not work if the board has onboard GPS.

Users should have a choice to enable this feature.

1 Like

Ah, so that’s why it didn’t work… Had the same issue