No Gps - flashing red

Hi,
I realised this has been previously covered but with no really definable results of what was up.
I’m still new to this (someone’s gotta be) and i have managed to install python 3 and reflash my two boards with these latest firmware after detection.
My problem is as above -no gps- on the screen this worked briefly for a few minutes after reflashing but stopped on pairing with the app.
I believe both boards are v1.0 neo6m, would really appreciate a hand to get these up and running.
I don’t know if it makes a difference but i don’t have any 18650 batteries yet and have been running on usb battery packs only.

Update, flashed a lower firmware no. Then paired to the app, updated to the latest firmware again left for 15mins and bang, she’s a runner.
Convinced this is entirely my own fault for running without a battery fitted. The second you disconnect from the power the display goes from no sats to no gps and a flashing red light!
Solution, fit battery re flash to 1.2.63, pair and update to latest?

This may actually be to do with some fixes that are being done on the hardware side. Here is some info from Caveman99 on the discord:

My understanding is that the (hopefully) soon to be released 1.2.65 will include the code to reset the GPS chip. Until then, there is some code you can run using arduino which will reset the GPS chip which I have used and it sorted my t-beam out immediately. The code is here: TTGO_T-beam_GPS-reset/GPS-T22_v1.0-20190612_v1.1-20191212-resetGPS.ino at master · eriktheV-king/TTGO_T-beam_GPS-reset · GitHub

After using that you should be able to re-flash to 1.2.64 and hopefully your GPS will work.

1 Like

Another possibility is to use pre-version from thread T-Beam v1.1 GPS always powered on in 1.2.64 - at least it works with me and it will do a factory-reset

Thanks for replying, please excuse my massive knowledge gap here but how do I get that code into the board?

download and unzip the file and you will find the firmware to your board like tbeam. I think you already had experience flashing the FW

Ah yes, getting the reset code going can be entertaining. You need to download Arduino. That then needs setting up, I have the following two URLs added to the additional boards manager urls section under preferences under file:
https://dl.espressif.com/dl/package_esp32_index.json https://adafruit.github.io/arduino-board-index/package_adafruit_index.json

Then on Tools → Boards → Boards Manager you will need to install esp32 from espressif

Under Tools ->Library manager you will need to install axp202x_library and TinyGPS.

The code is based on the old version of the u-blox library that is now depreciated. It can be found here: GitHub - sparkfun/SparkFun_Ublox_Arduino_Library: Library to control UBX binary protocol and NMEA over I2C on Ublox GPS modules. With instructions on how to install it here: Installing an Arduino Library - learn.sparkfun.com

That should set it up. Then load the code from the above link. On Tools, select Board → ESP32 Arduino → T-beam
On Tools → board, check that the correct com port is set
Then Sketch, Verify/Compile - At this point it will give errors if other libraries need to be installed.
Then once compiled successfully, Sketch and upload.

If you open the serial monitor before uploading, it should show you the output from resetting the GPS.

Then re-flash with meshtastic.

Let me know if any other libraries are required or any steps I’ve missed in case we need to point anyone else to this. Similarly if anyone else spots anything wrong with the above.

Awesome, sounds complicated - I’ll definitely give it a go though.
Cheers

Please don’t bother with the reset sketch and Arduino, the same code is in this new firmware: https://github.com/meshtastic/artifacts/blob/device/pr/pr1458-firmware-1.2.64.a9fcc77.zip?raw=true

The more people give FEED BACK on this, the faster we’re doing a 1.2.65 release. i WON’T release this without proper feedback it’s actually resolving the ‘no-GPS’ Problem…

2 Likes

Will do, look forward to the new code.
Cheers

1 Like

Sorry, I did not notice that there is even a newer FW available - will test this tomorrow. The previous FW already solved my no-GPS problem as i stated in T-Beam v1.1 GPS always powered on in 1.2.64 - #16 by kfh857

Yes, it’s the same mechanism, just a bit fine tuned… If the previous iteration soved it for you, no need to test again.


I guess this means the screens dead,
Well unfortunately after best part of a week and around £100 spent this is a complete right off. Sorry folks but I’m out, really disappointed, and yes i know there still in development but after getting sucked in with all the videos on you tube working and i didn’t see them picking through code line by line - i got mine sort of going for 5mins top.
Sorry for the rant but I clearly don’t have the skills to make this happen even after 14 years as a communication system op in two armies which makes me even more disappointed and will think twice in future before attempting any other projects.
Thank you for trying to help anyway.

If you look at the bottom right portion of your OLED screen you will find some fine cracks. This just means there has been some force on the fragile glass. The screen is broken and needs to be replaced. Even without a screen the t-beam will work just fine.

No matter what way you take from here, there’s a reason folks put these things in enclosures, and there are quite a few really nice ones either to 3d-print yourself or buy ready made.

If i were you, i’d not give up just yet… :slight_smile:

1 Like

Cheers, guess I’m more disappointed with myself for not getting it working.

Hi, I have a Lilygo TTGO Lora32 - Neo6m and after updating to version 1.2.64 the GPS seems not to work: no GPS and the red LED flashes continuously.
To use the device again, I had to downgrade to version 1.2.60. Now the GPS works but the red LED continues to flash with short random interruptions of a few seconds.

Please read No Gps - flashing red - #9 by caveman99

I noticed with previous/older version that 60 seconds might be too short time to wait to see if GPS has any activity
??:??:?? 0 Meshtastic hwvendor=4, swver=1.2.64.8e8158eb-d, hwver=1.0
…snip
??:??:?? 2 [Screen] Screen: Started…
??:??:?? 2 [GPS] NMEA GPS time 2022-05-29 18:25:59
00:00:02 2 [GPS] Upgrading time to RTC 1653848759 secs (quality 3)
18:25:59 2 [GPS] Read RTC time as 1653848759 (cur millis 2657) quality=3
18:25:59 2 [GPS] publishing pos@0:2, hasVal=0, GPSlock=0
18:25:59 2 [GPS] No GPS lock
…snip
18:26:56 60 [GPS] GPS is not communicating, trying factory reset on next bootup.
18:26:56 60 [GPS] Saving /prefs/db.proto
18:26:57 61 [GPS] Saving /prefs/radio.proto
18:26:57 61 [GPS] Saving /prefs/channels.proto
… snip
18:27:13 77 [GPS] hasValidLocation RISING EDGE
18:27:13 77 [GPS] WANT GPS=0
18:27:13 77 [GPS] publishing pos@6293bb01:2, hasVal=1, GPSlock=1
18:27:13 77 [GPS] New GPS pos@6293bb01:3 lat=49.xxxxx, lon=8.yyyyy, alt=0, pdop=9.00, track=0.00, sats=4
18:27:13 77 [GPS] onGPSChanged() pos@6293bb01:4, time=1653848833, lat=49xxxxxxx, bat=1
18:27:13 77 [GPS] updatePosition LOCAL pos@6293bb01:5, time=1653848833, latI=49xxxx, lonI=8yyyy
18:27:13 77 [GPS] Node status update: 2 online, 3 total

I think getting the clock could be counted as GPS-activity, although the time most likely came from RTC

The old versions are not of any use for comparison, some libraries have been removed and we are talking directly to gps chips now without a library so they don’t work the same at all.

“GPS is not communicating” is referring to an intelligable data stream, which the GPS chip in right mode will send every second, even if it doesn’t have a lock. 60 seconds is plenty of time to assess whether we can parse that data stream and the checksums are correct. And that time indeed came from GPS. I’m a bit stumped why it won’t detect these sentences as valid.