TBeam TTGO V1.1 upgraded from 1.2.65 to 1.3.40.e87ecc2

TBeam TTGO V1.1 upgraded from 1.2.65 to 1.3.40.e87ecc2.

GPS worked fine with many versions of 1.2, now that I’ve updated to 1.3.x - “No GPS Module”. (Yes, I set region) Red light flashes along with blue light about once every 2 seconds.

Where did my GPS Module go?

There were rumors of a fix in 1.3.41 but I flashed it and its the same thing for all of my tbeams, n8 and 6’s

It is fixed in 1.3.41, you may need to power cycle twice still to do a gpa reset.

If resetting power does not work, reflash 1.2.65 and see if that works, then reflash 1.3.4x. There is another fix, applying gps controls via simple sketches but it is harder to do. Doing reset to 1.2.65 worked for 4 of my Tbeams, then back to 1.3 again and GPS still worked.

1 Like

Nah, loading the code/sketch, compiled and upload is my preferred method whenever theres a usb-uart driver and I can leave boards in their production environment. I’d much rather debug than load someone elses code and wait for something to go wrong.

Anyways, I’ve reset the GPS on my n8m board using the OEM sketch and eriktheV-king’s, then flashed 341, followed by several power cycles and factory resets. I will stick it in the window today and report back this evening.

Garth if I can’t get it working overnight I grab the monitor logs and upload them for you tomorrow

Ok - got 1.3.41.80ddb81, just ran the device-upgrade.sh, and upgraded from 1.3.40.e87ecc2. It’s now working. Seemed slower connecting to the sats than with 1.2.65, but it’s picking up 4 from my office window now.

I’ll now proceed to do a device update from 1.2.65 now, see if it makes the upgrade leap from 1.2.x to 1.3.40.e87ecc2

Ok - I’ve also directly updated from 1.2.65 to 1.3.40.e87ecc2, and that seems to be successful as well.