Problem Flashing Heltec V2.1 with Meshtastic Flasher

Edit: even a blind hog finds an acorn every once in a while… seems I was missing driver software for the PC to communicate with the LoRa boards. See my reply below. Issue resolved.

Recently purchased a pair of Heltec ESP32 LoRa boards from amazon (ASIN ‎B07HJ49VN8). Downloaded and ran the Meshtastic software flasher and have not been able to get it to work. Tried all the troubleshooting suggestions. Installed python and Git to attempt manual flashing of driver software to no avail…

I’m sure stuff like this gets old hearing. Brand new to LoRa, halfway computer literate… so this is a bit frustrating to say the least.

Below is a screenshot of the run command and screen I see on the Meshtastic Flasher software. The “Flash” button remains greyed out no matter what options I select. Any ideas?

Well, seems like the next thing I tried solved the issue. Digging around on the meshtastic site, there was a note suggesting the need for driver software to properly communicate with the ports on the PC.

SiLabs CP210x Universal Windows Driver solved the problem!


I just managed to install the software on Heltec 2.1 with Meshtastic version 1.0.93 on OSX.
A few weeks ago I had a lot of problems with ESP32-CAM. I had to try several USB cables. It seems the low quality ones are only for charging.
Now when I took the correct cable it worked immediately. (Now trying to connect a mobile).

Yesterday I had problems to connect from the android app via Bluetooth (non of the Pin Codes 0000, 1234 neither 123456 with or without pressing a device was working.
If the evening 500m away with device #1 i saw that there is a code on the display coming up when trying to connect on the LoRa Device #1 with a 6 digit code. Entering this on the android app/phone and i was able to connect.
Also i sent a message from #1 inside the town (no sight) to the device#2 which was 500m+ away. This morning i saw the message had arrived @#2 (through the 500m distance as the sending device was off).
As iOS seems a little more difficult I connected the 2nd unit to another Android pad device. Again the PIN code for #2 from display.
Now i am able to communicate between the devices #1 and #2 through the telephones/pads. Using the most recent 1.2.57 … software.
The bluetooth link/connection of #1 and #2 was kept over night.
Maybe i get another unit with GPS inside and play with 3 units.
From what i see its good way of sms like communication when there is no infrastructure of whatever (but electricity). I have not tried channels/encryption.
Well done.

Thanks for your post, saved me some time. Can confirm I also needed the Universal Windows Driver for Windows 11, flashing the newer Heltec v3.1

Download link for the Silicon Labs driver,

You could have saved yourself even more time versus having to diving into a year+ old post by just going to the website. It’s in the docs: ESP32 Serial Drivers | Meshtastic

1 Like