Heltec Capsule Sensor V3

Has anyone else ordered or received the new Heltec Capsule Sensor V3 boards? I just pre-ordered 2 of them. I’m also wondering if there will be a specific firmware release for these or they will just use the same Heltec V3 firmware?

I also found on their site they have a promo code to order them, saved me about $5: 4CVQ6KAC

They are up for pre-order and will be shipped on March 8th.


We have limited information on this device. They mention it supports Meshtastic but that it isn’t suitable for Meshtastic but also ships with Meshtastic pre-flashed. One of the developers has ordered a couple of the devices so we’ll know more when those are received. There’s a couple of YouTubers that have received them though and show them running Meshtastic.

250mAh battery… for an esp32 board (with GPS) that gives maybe 2 hours of runtime :no_good_man:

1 Like

if you use it as a gps tracker, what it was built for:
role “tracker” hopefully it might sleep most of the time using very little energy and battery will be good for some days.

not sure if that will work as in rak modules, but i ordered one :slight_smile:


I’ve ordered a pair to put on my kids while we hike. The ESP32 board surprised me in this use case, but we’ll see how it goes!

I also swore I wouldn’t buy another device that didn’t have a USB-C charger, but made an exception for the IPX claim.

1 Like

Anybody received and tested out the battery runtime? They mention if set to send every hour it’ll run for 6 months! If the send can be set then this has the potential to run a decent time (on a dog/person/child).

  Hey folks just a friendly warning!

(I originally posted this to the Heltec community but im getting antsy and desperate for a solution lol)

I just received my CapSule Sensor v3 and I’m already running into issues, it isn’t able to detect or use the internal gps, and after changing settings through the Meshtastic app, it’s boot looping.

1: I’ve set it up the device in the Meshtastic app. When I attemped to change the position settings, no matter what I did the gps mode defaults to disabled. I’ve changed it multiple times to ENABLED and after it reboots it’s always DISABLED.

2: After changing the device settings to rebroadcast KNOWN_ONLY, it boot loops when attempting to change any settings at all. Nothing I’ve done fixes this issue. I’ve used Wireless Boot to erase and reinstall the firmware multiple times. It still boot loops when attempting to interact with it through the Meshtastic app, and I can’t enable Wi-Fi through the settings to change it back through the web client. Unfortunately It’s stuck.

Lucky I’ve purchased 2 (one for myself and my wife) and for now the second works, but I’m not going to change any settings on it until I know what causes boot looping, and why the gps isn’t functioning.

Hopefully and update to Meshtastic or the CapSule firmware will fix the broken one.


thank you for the warning,
i will handle my one “with care”, when it arrives…

have you tried changing the settings for “Redefine gps pin rx/tx” ?

Hi everyone, does anyone happen to know when they will be changing chips or UK suppliers will be supplying them?

Hi there Phaneron1991,

Just got mine in the post, but having difficulty in locating Meshtastic software for this device. What version of Meshtastic are you using? And for what device (I.e. heltec v3 or another device?).

I have loaded the V3 version but it doesn’t even allow me to connect via Bluetooth.

Cheers mate!

1 Like

i just received my heltec capsule
it is preflashed with an heltec-generated special version of meshtatic
better dont change the firmware until there is a version for this device.

still having to find out, how to get more than 2 hours runtime as a tracker !

1 Like

Does anybody know what device to choose in the Meshtastic flasher app? I’ve just received my Heltec Capsule Sensors.

if it has a meshtastci firmware already, better dont flash now… wait some time

It is not available in the flasher, we are working to get the code from Heltec


Are there any instructions online for getting set up? How do I pair it?

Not supported at all yet by Meshtastic, you need to check with Heltec

i have received it today, its working well, running the preinstalles firmware. and connected with newest android app. gps fix is fast, getting 8 sat in short time.
setting channels, admin channel, BLE , everything works. did not try the modules ! i have read before that this thing can be bricked by playing with settings too much :slight_smile:

just battery runtime is almost less than an hour.
so its an absolutely useless device at this moment !

if it was possible to get it to sleep mode between gps fixes/sending it would be a very good device

i have not managed to do that, i tried “Tracker role” with power-saving enabled. . (what gets the rak devices with gps installed to sleep untik the next fix… but these are not esp32.) and some more settings, but i cannot get it to sleep… all help welcome ! i would like to use this thing !

maybe soon, there will be a (+/- meshtastic )firmware that will enable sleep mode.
then it will be a great tracker device !

with runtime of 1 h and maybe 20 seconds for each fix, it could be good for 180 trackings…
numbers depending on runtime per fix…so it might also be 300 trackings… some days of tracker runtime possible…

1 Like

Ordered mine at begin of March, still not here but did get the excepted in customs email about 2 weeks ago

Mine arrived yesterday too! Thank you for the recommendation on the dog tracker thread.

Very impressed with the size weight. Mine was pre-installed with Meshtastic too.

I have been unable to get a GPS fix, as another post further up noted. Any tips on this would be greatly received. I unscrewed the base and confirmed what looks like a GPS board to be present. I left it upside down (from what i can see the GPS antenna is in the base / unchamfered end) overnight and still no fix.


1 Like

No special tricks here. Just a regular Bluetooth pair (123456) and then set region etc.