Getting started - Again - Versions 1.3+ 09/07/2022

"It does a lot under the hood to prevent you from needing to use the terminal. "

Howdy,

I am trying to get my devices upgraded and things are not going smoothly. Previously I used the unofficial getting started website but that is no longer valid since the links are outdated. When I attempt to proceed with the get updates with the old gui flasher the title bar says there is a new version available (of the flasher?) and the attempts to update the list of firmwares via “get versions” to get 1.3+ versions all return “false” results in the command prompt window that appears, but when done none show in the drop down of the flasher gui when looking for 1.3 versions.

I tried starting fresh from the official getting started page and though it says the gui flasher "does a lot under the hood to prevent you from needing to use the terminal. " the webpage that loads requires using a terminal to install the flasher in the first place. I have tried, but the commands for windows do not work in the python window that opened when I made sure it was updated as the instruction specify - Oh - perhaps I should try those commands in a standard command prompt window? I will try that and report back for those that are as confused as me :slight_smile:

Nope that was not it - I will try this which I found during an internet search:

The tutorial he is attempting to follow in the video is below:

We will be flipping everything to 1.3 here in the next few days, that guide and video are super old.

1 Like

Ok, sounds like I was jumping the gun a bit for my skill set, funny because I thought I was late to the party :slight_smile:

Looks like “Curtis” from the video and I both could not get the meshtastic gui flasher to load the way I think it was supposed to via the instructions, so Curtis updated the firmware via the command prompt. I will try it that way after I dissect the end of the video a bit.

Yeah sadly the scripts tend to work better if the device does not already have meshtastic on it, and python is kind of rough on windows.

1 Like

Just noticed this as well so it’s nice to know I’m not the only one struggling

"we hope to promote 1.3 to the main version for both the CLI and Meshtastic Flasher soon”

Channels are not backwards compatible with different versions of software and firmware :frowning: