Meshtastic

First Boot, Flashing Screen / Logo

tl’dr --Is a flashing logo screen normal when you turn it on the first time? Or is it a short in my bad solder job?


Turned on Meshtastic T-BEAM v1.1 (433mhz) for the first time after soldering the screen on myself, and the screen keeps flashing the logo when I plug it into power via USB. Is this normal?

Waiting on my Android OnePlus 6T to come in the mail (and batteries), so I have nothing to connect to it with to see if that would do anything.

Was worried it’s a short in the solder job. My first board, first time soldering since high school.

I scraped off any excess, but it’s still a possibility I messed up. I got the pins right though, I know that much.

It has the factory 1.0 Meshtastic software on it. I run Mojave MacOS, and can’t open the ESPHome Firmware Flasher software that’s currently available.

Keywords for later searchers: flashing logo, flashing screen, first boot screen flashing

The screen should not flash. So either soldering or double check that you’ve got the right firmware for your board type installed.

I’ll see what I can do about updating firmware, and if that isn’t it, it’s likely my terrible soldering job. Thanks so much for the reply, so quickly!

Make sure you are uploading the firmware-tbeam-US-1.1.32 file not the firmware-tbeam0.7-US-1.1.32 file (assuming you are in the US).

2 Likes

I had the same issue. FIrmware update did the trick.

You’re a ray of light, you “fat rat bastard” lol. (Love the alias).

Issue with flashing --ESPHome Flasher doesn’t see the Meshtastic on my serial port. I even plugged in all my virgin un-soldered boards and still, nothing appears on the “serial port” field. I rebooted, tried plugging in before opening the app, then after opening the app. Rahh.

(Can only include one image as I am a new user).

So I think I have a software barrier to entry here. Is there some other MacOS-friendly software I can use? I have Home Brew installed.

Also --what’s this weird little block behind the antenna? It’s just taped on, what’s it for? Do I need to connect it? On all my boards, they’re all poorly attached, wobbly-looking sad things.

I’m in the Philippines, and I got the “470MHz (433MHz version)” from this page: https://shopee.ph/product/328933173/3560433682

It came pre-flashed with version 1.0. I was going to flash it with “firmware-tbeam-EU433-1.1.32.bin” but I didn’t get that far. ESPHome isn’t seeing anything on my serial port. Looking for another flashing software. I had no luck on un-soldered boards, either.

I looked over my soldering job in daylight, it isn’t bad. I don’t see any connections touching eachother.

That’s the GPS antenna. The mounting is a bit how-you-doing.

It’s generally ok where it is, if you’re using the GPS outside. If indoors, you want it pointing up.

This might sound stupid, but it stumped me for at least an hour while trying to flash mine. No matter what I did it did not show up as connected to my computer.

I was using a “charge only” USB cable, it has to be a cable that is able to transmit data as well as power.

2 Likes

AH, okay.

As I understand it; the only soldering I am req to do is to attach a screen, and even then, screens are optional. Sound right?

I tried the cable I got with my HackRF Portapack. It flashed that okay. I think this issue I’ve got is software.

Spot on.

There’s a button sequence you can push to do the BLE pairing if you don’t have the BLE code. Pairing for BLE was really the biggest use for the screen, but we had a contributor submit the code to help pair without needing the code if you have physical access to the device.

Brilliant. Headless it is, at least for half the batch I’ve got.

For reference, here’s the change for headless ble pairing.

I don’t think it’s been discussed much on this forum. Code says you can either use the default pin of 123456 or double-click on the button on the device.

2 Likes

Keeping that in my pocket. Really appreciated.

I read the code again. The default pin of 123456 only works if no screen is detected.

1 Like

Continuing from this thread:

Thanks to @mc-hamster confirming my need for the following drivers on my MacOS operating system (Mojave), I successfully flashed my Meshtastic to the most recent version using ESPHome Flasher 1.2.0 (suggested by IZ1IVA) --has thusly restored my faith in my own soldering skills in the process.

Happy to be one of the cool kids. Now all I need is my Android phone(s) and 3D printer to arrive.

hackers_spacesymbols

4 Likes

Worth mention, I just didn’t RTFM effectively; documentation mentioned the drivers.

If your board is not showing under Serial Port then you likely need to install the drivers for the CP210X serial chip. In Windows you can check by searching “Device Manager” and ensuring the device is shown under “Ports”.

Calling myself out, but now there’s this thread for this for future noobery akin to my own! Anyone reading this, with MacOS, if the current version of ESPHome doesn’t load for you, try this version. It worked for me.

2 Likes