TBeam TTGO V1.1 can't update firmware past 1.2.65

I used the GUI flash tool from the Github and tried to update two TBeam TTGO Lora32 (ublox NEO-6M-0-001 T22_V1.1 20210222) to the latest firmware. They came with 1.2.4x when I received them but the newest version in the dropdown is 1.2.65. I updated both but when I pair them to the latest version of the app on android I get a message that the firmware is too old.

So, what is the version of your app on android. If it is 1.3.xxx version instead of 1.2.xx you will get that message

Yes, it is, but I want my radio to update to the latest firmware which I can’t currently because I can’t select it in the GUI flash tool

you have to install the pre-release version of the flasher to install 1.3 firmware

pip install --upgrade meshtastic --pre

Do you run that in the venv after you install the regular flasher? I tried it and when I started the flasher again it still only went up to 1.2.x

I close and delete the old flasher before installing a new one when switching back and forth

pip uninstall meshtastic-flasher

Ok I’m not sure what I am doing wrong. Here is what I did. I uninstalled using your command then then deleted the whole directory (some_dir). I then setup the venv according to the install instructions from the website. After getting getting into venv I ran the pip command you provided above (pip install --upgrade meshtastic --pre) to install the pre version. I then installed the flasher with (pip install meshtastic-flasher) and tried to run the flasher and got the following error:

(venv) PS C:\some_dir> meshtastic-flasher
Traceback (most recent call last):
File “C:\Users\crossfire\AppData\Local\Programs\Python\Python310\lib\runpy.py”, line 196, in _run_module_as_main
return _run_code(code, main_globals, None,
File “C:\Users\crossfire\AppData\Local\Programs\Python\Python310\lib\runpy.py”, line 86, in run_code
exec(code, run_globals)
File "C:\some_dir\venv\Scripts\meshtastic-flasher.exe_main
.py", line 4, in
File “C:\some_dir\venv\lib\site-packages\meshtastic_flasher\main.py”, line 11, in
import meshtastic_flasher.form
File “C:\some_dir\venv\lib\site-packages\meshtastic_flasher\form.py”, line 31, in
from meshtastic_flasher.settings import Settings
File “C:\some_dir\venv\lib\site-packages\meshtastic_flasher\settings.py”, line 11, in
from meshtastic_flasher.position_form import PositionForm
File “C:\some_dir\venv\lib\site-packages\meshtastic_flasher\position_form.py”, line 9, in
import meshtastic.radioconfig_pb2
ModuleNotFoundError: No module named ‘meshtastic.radioconfig_pb2’

To make it clearer, here are the exact commands I performed in order of operation:

(venv) PS C:\some_dir> pip uninstall meshtastic-flasher
(venv) PS C:\some_dir> exit
PS C:\some_dir> rm some_dir
PS C:\some_dir> mkdir some_dir
PS C:\some_dir> cd some_dir
PS C:\some_dir> python -m venv venv
PS C:\some_dir> venv\Scripts\activate
(venv) PS C:\some_dir> pip install --upgrade meshtastic --pre
(venv) PS C:\some_dir> pip install meshtastic-flasher
(venv) PS C:\some_dir> meshtastic-flasher

do the same for the flasher and it should work

pip install --upgrade meshtastic-flasher --pre

And then you should see 1.3.39 when you get versions

Ok that worked, thanks! Now when I try to flash it, it says I have to jump pins GND to BOOT0 but my board doesn’t have a BOOT0 pin. None of the previous flashing pre 1.3x needed a jumper. This is the Lilygo TTGO V1.1
There is a pin labeled just 0, would it be referring to that? Also thank you for all your help!

Just click ok on the modal and select tlora-v1 from the device drop down and flash

I’ve found I’ve had to use the “TBEAM” firmware to get any sort of response out of my LILYGO T22_V1.1, if I tried to use the tlora-v1 the screen completely dies on me. It doesn’t seem to recognize the GPS Chip anymore however with the TBEAM Firmware.

That makes sense, the 1.1 is a tbeam

If you power cycle the device twice (not reset) waiting five minutes between each power cycle it will factory reset the GPS.

I made mention I had to use the tbeam for the other guy who owns these devices, as you had suggested the tlora-v1 to him.

I’ve noticed the bluetooth is far more flaky on 1.3.39 however, it wont even connect to my Android device, so I may downgrade to a previous version of 1.3 or even back to 1.2.

I’ve tried power cycling the units a couple of times now to see if I could get the GPS to reset, however it still just keeps telling me “No GPS Module”.

Ok so I was able to get it flashed using tbeam, tlora-v1 kept failing to flash. I haven’t had any issues with gps, but one of my boards sometimes fails to connect via bluetooth until I reboot it a couple times.

Is it safe to assume that a newer release of Android Meshtastic (currently at 1.2.67 from the play store) will offer a TTGO firmware update to 1.3.x?

1.2 and 1.3 are not compatible, there is not going to be an OTA upgrade path,

I’m trying to follow Shanty5454 along on Linux rather than Windows and I’m getting an error…

I have with no problem:

pip install –upgrade meshtastic –pre

But when I run

pip install --upgrade meshtastic-flasher --pre

I get:

error: legacy-install-failure
Encountered error while trying to install package.
╰─> reedsolo

And I’ve run out of google links for ideas on how to get past.


Here’s the entire output from running:

pip install --upgrade meshtastic-flasher --pre