SOLVED! Help installing with other than esphome-flasher

I’m using windows 10 and so far I have successfully installed latest firmware on t-beams using esphome-flasher. Issue is that I am not able to load meshtastic-web files onto meshtastic.local/static as it appears there is not enough memory;


I should mention that these T-beams originally came with SoftRF pre-loaded. I tried erasing flash and then installing with espflasher again but result is the same, unable to upload three mestastic-web files to static page.

I tried to follow commandline installation instructions but this does not work on windows, cannot execute I have been playing with PlatformIO inside VS Code all day but cannot figure out how to clone meshtastic git repository. I followed the wiki but when I click ‘Clone Git Project’ nothing happens. Do I need Git extension? If so, which one, there are so many of them?


1 Like

The partition table from softrf has carried over. Does anyone know how to change the partition table?

Okay, so installing with some other means is not going to fix it.

I’m looking at some ESP32 partition assignment info on various forums. I’ll try to work with that and will post here what I came up with.


Is someone able to tell me what is the default partition table for T-Beam or even better take a snapshot of .csv file? I’m guessing we want OTA support?

I found this guide on how to change or modify partition table in Arduino IDE, at least I have some idea on how to use this.

1 Like

So I tried to change partition scheme using Arduino IDE;

After setting board preferences as shown above, I picked a simple sketch and then compiled and uploaded this to t-beam. Then I pulled the battery and unplugged USB cable to restart t-beam.

Loading meshtastic using esphome-flasher, setting wifi credentials with meshtastic python script, and restarting t-beam…no change :frowning: , http://meshtastic.local/static still the same.

I’m out of ideas, for now.

Does anyone else use esphome-flasher and gets a different looking http://meshtastic.local/static?

1 Like

ahh so this is my problem… i thought i was going crazy

1 Like

I just tried logging onto meshtastic.local/static on a different board (TTGO LORA32 that had Pax counter installed on it when I got it), same thing, no luck. Static page is identical to what I had with T-Beams.

TTGO LORA32 was also flashed with esphome-flasher tool.

1 Like

i just had success flashing a simple program over a heltec esp32 device. then reflashed meshtastic with the esptool in command line (anaconda) then uploaded the 3 webfiles. ITS WORKING!!!

1 Like

Well, I guess it is time to sequester USB keyboard again (I have a raspberry Pi running Linux but have to steal my wife’s work computer keyboard).

I will try flashing a simple Arduino sketch again and then flashing it with meshtastic using from Linux terminal.

Anyone that bought a board with SoftRF pre-installed;

  1. Remove battery, flash simple sketch using Arduino IDE, choosing partition scheme with larger spiffs, then reset board. I’m not sure what this accomplished but I’m thinking different partition scheme was flashed onto t-beam???
  2. Install Meshtastic using Linux terminal using, see meshtastic-device Git page.

Now you have a device that will support meshtastic-web installation :slight_smile:



i flashed just a random sketch i was working on to ping an ultrasonic sensor. I haven’t fiddled with changing partition scheme, but there was a setting to overwrite the program and wifi settings, I selected that, but i no longer see that option.

anaconda is a terminal in windows you can run python and pip in

//Adapted from David A. Mellis' code for Ping sensor

const int trigPin = 2;
const int echoPin = 14;

void setup() {
// initialize serial communication:

void loop()
long duration, inches, cm;

digitalWrite(trigPin, LOW);
digitalWrite(trigPin, HIGH);
digitalWrite(trigPin, LOW);

duration = pulseIn(echoPin, HIGH);

// convert the time into a distance
inches = microsecondsToInches(duration);
cm = microsecondsToCentimeters(duration);

Serial.print("in, ");


long microsecondsToInches(long microseconds)
// According to Parallax’s datasheet for the PING))), there are
// 73.746 microseconds per inch (i.e. sound travels at 1130 feet per
// second). This gives the distance travelled by the ping, outbound
// and return, so we divide by 2 to get the distance of the obstacle.
// See:
return microseconds / 74 / 2;

long microsecondsToCentimeters(long microseconds)
// The speed of sound is 340 m/s or 29 microseconds per centimeter.
// The ping travels out and back, so to find the distance of the
// object we take half of the distance travelled.
return microseconds / 29 / 2;

Wait a sec, the title of this thread says “SOLVED!” but there’s nothing on what you did. Can’t leave us hanging like this. That would be worse than the unresolved cliffhanger of Quantum Leap!

Edit: Scratch that, you updated your post. So glad this worked out. Thank you for sticking through it. We just learned something.

LOL I was editing (composing a novel) my post. I actually had a 10 step procedure written but decided to truncate it a bit. …

1 Like

You can use “git bash” to run .sh program

Pip and python can be used in the original cmd of windows, to do all the meshtastic install and set up you can do all on windows without linux

I’ll have to look into git bash, I couldn’t figure out how to run .sh in Windows, that’s why I turned to Linux. I even installed Debian from windows store (it is terminal that runs in windows) but then you need to download firmware .bin files and I didn’t know how to do that in terminal.

Long story short, I don’t really know what I’m doing.

I am able to run meshtastic python scripts in windows, took me some time to set this up. Looking back it is so easy, just like instructions say to do this. My problem is not knowing you have to be in the directory where scripts are located in order to run it. General computer literacy issues.
Then I learned how to set path in windows to Python folder and scripts folder, that way I can run meshtastic as soon as I start Command line.