New LilyGO® T-Beam Supreme product

Source: LilyGO® GitHub


They have contributed a build for the new board and sent a couple to our firmware dev so we should be ready to go when it is released for sale.


SoftRF project has published some information about this new product.

as well as the link to purchase it on AliExpress.


LilyGO® PCB&A video

How long until there’s a Meshtastic version?

This device is already supported by Meshtastic.


iv got my hardware (supreme) already, which firmware file should i use?

it is supposed to be this one -

web flasher sits at preparing forever and never does anything
command line flashing fails as the serial port disconnects as soon as it starts
putting the device into a bootloader/recovery mode shows on the display that its loaded with GitHub - adafruit/tinyuf2: UF2 bootloader based on TinyUSB for embedded devices such as ESP32S2, STM32F4 and iMX RT10xx

iv tried flashing via the expansion board USB-C and also via the core module USB-C (whilst disconnected from the expansion board.

tried with mac and linux and two cables and still no joy.

connecting with the web flasher console does show the hardware is alive and running softRF in the console

so a little bit stuck as to what to do here

Folks have succeed with LilyGO T3-S3 board which is also based on ESP32-S3 -

T-Beam Supreme initial Meshtastic flashing procedure is expected to be very similar to T3-S3 one.

my current feedback is that it is not similar, unless im missing a major step!
The serial port disconnects as soon as any attempt to flash is made, but opening up /dev/ttyACM0 in a terminal emulator at the correct rate (460800) shows the device itself is alive and well running softrf.

./ -f firmware-tbeam-s3-core- -p /dev/ttyACM0
Trying to flash firmware-tbeam-s3-core-, but first erasing and writing system information v4.5.1
Serial port /dev/ttyACM0

A serial exception error occurred: Could not configure port: (5, 'Input/output error')
Note: This error originates from pySerial. It is likely not a problem with esptool, but with the hardware connection or drivers.
For troubleshooting steps visit:

One should put the T-Beam Supreme into ROM bootloader mode by following “press RESET → press BOOT → release RESET → release BOOT” procedure prior to executing the script.

1 Like

Thats the ticket, press and hold boot whilst powering on for about 6 seconds, then release.
device responds to queries from esptool and flashing is possible.

at present based on current observations

  • Display non functional - even when autodetection is disabled and screen type is set manually (screen works under softrf though)
  • none of the onboard sensors are detected/functional (air pressure, IMU, magnetometer)

None of the sensors are supported, screen should work, it was defined manually in the s3 firmware.

Did you initially flash the device using the cli scripts? It’s been reported that if the initial flash is done via another method the screen doesn’t work work. After the initial flash the web flasher should be fine.

I also have the problem with a non working display. I installed the recent firmware via web installer and cli. This is the output of the log concerning I2C (with a long pause after “Scanning for i2c devices on port 1”:

Scanning for i2c devices…
DEBUG | ??:??:?? 2 Scanning for i2c devices on port 2
DEBUG | ??:??:?? 3 I2C device found at address 0x34
INFO | ??:??:?? 3 axp192/axp2101 PMU found
DEBUG | ??:??:?? 3 I2C device found at address 0x51
INFO | ??:??:?? 3 PCF8563 RTC found
DEBUG | ??:??:?? 4 Scanning for i2c devices on port 1
INFO | ??:??:?? 130 2 I2C devices found
I also set the display manually to SH1106 without success. Any further suggestion what I can try?

Did you do web installer or CLI first? When you did CLI did you ./device-install or ./device-update?

I first tried using the web installer (Tbeam-s3-core; wipe and install). Then I used ./device-install (“./ -f firmware-tbeam-s3-core-”). I also tried firmware-tbeam-s3-core- I don’t think. it’s relevant, but just to mention it: I use an Apple Silicon MacBook.

Short update:
Meanwhile I reinstalled SoftRF (display was fine). Than I reinstalled Meshtastic via CLI without success: display black. Still a long pause (approx. 1 minute) during boot process, after “Scanning for i2c devices on port 1” before boot continues.