Factory Reset of Lilygo T-Beam V1.1

I have a Lilygo T-Beam V1.1 that does not seems to support serial connections nor blue-tooth connections to the web based interface. I tried to upload new firmware via the command line GUI but that also could not get in through the serial connection.

Is there a way to factory reset this board?

I tried the CLI, but it appears that is also not working for this board. Seems like the serial connection is disabled? Any ideas on how to enable it? Looks like once it is disabled, it’s over?

Serial Console[(Device Configuration | Meshtastic)

Acceptable values: true or false

Disabling this will disable the SerialConsole by not initializing the StreamAPI

i think i had the same problem a while ago.
i disabled serial of one module :slight_smile:

i succesfully flashed the device with meshtastic flasher.
( ithink it was the older version, but also new version should do the job )
if i remember corretly, i had the flasher recognize another t-beam and then changed the cable to the “bricked” one and let the flasher do its job on it…

The web-based installer was able to get the job done. I had it erase and flash firmware on again. Thank you for the help.


1 Like