Meshtastic

Meshtastic iOS iPhone and iPad App Beta Testing Available

Hello all,

I have been working on a SwiftUI iOS app for Meshtastic this summer and have just received approval from Apple for external testing in TestFlight.

I love Meshtastic, but I am tired of carrying around this old Samsung phone and would love some help getting things ready for the App Store proper.

The app version in TestFlight contains a three tabs - bluetooth device connection, node list and details and a map of all the nodes in the mesh. I am currently finishing up messaging that works with the current primary channel configuration. I am interested in supporting the multi channel setup, but have never managed to make it actually work.

If you would be willing to test the app on your iPhone or iPad (iOS 15 required) you can use the TestFlight link If you are not in the US, UK, Canada, Germany or Sweden let me know and I will add your country.

Thanks,

Garth

5 Likes

I downloaded it and got it loaded into test flight but it wants me to update my os. I am already on ios 14.8 but I don’t want to update to ios15 yet. Any suggestions? I thought it only needed ios13 and I’m obviously beyond that.

EDIT: I looked into it more and you have it set to require ios15. Any way to change that to ios14?

I really can’t easily. I am using a number of SwiftUI and Symbols features that require iOS 15. I had planned to release for testing in a few months but the app is out for testing already because the iOS 15 features really sped up development.

1 Like

I have just started testing the app and wanted to give some initial feedback. Really nice UI, clear layout and very easy to connect to bluetooth. Things work as you’d expect them to. This is promising indeed, I have been hoping for something like this, like @garth I’ve been carrying an extra Android phone around.

The only other comment I have is that its a shame that there are no Topo maps on Apple Maps and that their existing maps are quite inaccurate for backcountry use (smaller lakes, rivers are missing etc.). Being able to switch to satellite view would help, but I’m not sure this will work for offline use the way it currently stores the map tiles on the Android app version. I know OsmAnd Maps has been mentioned as an alternative earlier, but can’t really comment on that other than it has the maps and it is possible to input POIs, tracks etc.

Great effort and I hope you continue, this is looking really great! Thank you!

2 Likes

Germany please? :slightly_smiling_face:

It would be great, thanks.

Germany has been added.

Hello, I would like to join the IOS app test.
Can add the place of Hong Kong, please?

Hong Kong has been added.

Worked well on iOS 15 and two Heltec v2’s (connected separately of course). VERY fast and smooth connection to the devices, was much better than the Android app for this step.

Thanks for all the great feedback everyone, keep sending those screenshots if you see anything weird!

I should have a build with basic messaging submitted for beta review by the end of this weekend.

1 Like

Thank you so much for releasing the iOS app. Just tested on my T-echos. Bluetooth discovery is much faster than Android. Nodes discovery takes a while still. One bug I noticed is that when I click on the nodes, the app consistently crashes for 2 of the 5 nodes I’ve got.

1 Like

Tested connection working with 2 of my Tbeam1.1 nodes. Scanning and connecting is super fast!

One node is on 1.2.45 and the other is 1.1.50, both seem to connect just fine, the 1.2.45 firmware version isn’t detected by the app. Both nodes say “Last Heard: 51yrs, 8 mths” and only my location shows up on the “Mesh Map”

Battery level seems accurate and SNR reads 0.0 (Don’t know if this feature is functioning yet).

Excited for the messaging functionality!

The timestamp is in time since the unix epoch, which is probably 51years 8 months ago, this is the second report I have gotten with devices that have 0 for the time, I will see if I can figure that out.

I am seeing a little bit of strange BLE behavior with my RAK and T-ECHO nrf52 based devices as well.

Looks great! And it works pretty well on iPad Mini 6 with two T-Beams on FW 1.2.39.

The T-Beam devices keep disconnecting though.

1 Like

Powered or on battery?

They’re on battery. I’ve set the ‘Device sleep period’ to 1 second and am now testing some more.

It sometimes doesn’t get the device name, and just shows numbers instead. I’ll submit a screenshot.

And sometimes power and SNR are both zero. I’ll also submit a screenshot of that.

Actually, I guess the latter point is symptom of the former. IE it has actually disconnected by the time it’s reporting zeros.

That was my suspicion, I think I need to figure out the CoreBluetooth equivalent of when the android app says “connected but device is sleeping”

Hi @garth I have just tried my tbeams running 1.2.44. All looks good. I too got the 51yrs 8 months but they have all updated now to connection times for today.
1 All the tabs work well and bluetooth pairing is fast and looks very stable.
2 I have not tried hiking yet only driving to various locations with one tbeam in my car and several at home. I find that to get it to update to current status (reseting last heard to 0 secs and confirming it’s new position on the map) I need to go into the app bluetooth and re-connect to the device. I did try using git bash to get my tbeams to update their position faster but that does not seem to change last heard time or map position. I had hoped my device positions would update automatically as I thought this would help hiking. Do I need to change something else?
3 A request! Could your App have a menu to set a friendly name for a device that would be seen across all App users on that mesh? I have tried to do this in the Android App but never had much success.
It’s a great App and I can start using right away for hiking! Thanks a lot for your work.

The problem goes away when the Tbeam is externally powered. So I think it’s to do with sleep mode.