Meshtastic Android 1.2.52 alpha

This version is only available via GitHub. This is not in Google Play or the Amazon App Store.

What’s Changed

Full Changelog : 1.2.51…1.2.52


  • @andrekir



This is a really awesome feature that we’ve added a toggle for. If you’ve grown tired of your device sleeping, turn that on and your esp32 won’t sleep again. Of course, this means the battery life is shot … but that’s the trade off.


I made a post yesterday about Tbeam FW 1.2.50 not found in Android 7 mestastic APP when upgrade from 1.2.45 to 1.2.50 / 51. Remove the post hour later because it solved.
This morning upgrade to latest FW and APK Tbeam FW 1.2.50 + meshtastic APP 1.2.52 trouble is back and not fantastic. I used GIT-BASH update + upgrade
Android 7.0 pair BT Tbeam and meshtastic APP 1.2.52 also see Tbeam device, but not give access to Tbeam device for some reason not clear.
Same as yesterday after upgrade to mestastic APP from 1.2.45 to 1.2.50 / 51.
I solve it yesterday to roll back FW Tbeam to early versions and upgrade every version from start but i think this is not the way to do it
How do i ADD pictures to post?

Android 7.0 Tbeam FW 1.2.49 is connecting with APP 1.2.52

there were no changes to Bluetooth, same Android requirements apply for scan/discovery of new devices: full location access (location permission + location services turned on).

if there are no devices listed on the app Settings tab and you see warnings:

make sure the device is awake and location services is turned on at the Quick Settings tray:


Yes, Tbeam showup in listed device, but not get the 2e network/channel screen .
I roll back to FW 1.2.49 and the 2e screen channel and name is there. I try again. Yesterday it take 4x times to get the channel/name screen come up.
Android 7.0 thingy using older BT ?

good, the app found the device. it’s just not connected (so you can’t change anything).

android-cloud-up-2016936b4e68d0285f298f61014c93d3 → if you see this icon at the right corner make sure your device is in range and awake.

on a TBeam the blue led flashes every ~1 second when awake and every ~30 seconds when sleeping. you can press the middle button to wake, reset button or feed power via USB cable.

Only in Android 7.0
BT pair window not always popup inside Meshtastic
its 5 cm away in front of tablet running meshtastic
After connect, not get the 2e window for name and range, it get and keep stuck in the picture i send
I not have this issue in earlyer FW nor APP versions.

Is this a Android 7.0 problem?

this suggests not being an app issue. if you can, rollback to device firmware 1.2.49 or even 1.2.48 to confirm and just ignore the button “upgrade to 1.2.50” for now.

I use Phone-Android-app 1.2.52 and tried to up update 2 Heltec (wifi_lora 32 V2.1) nodes from v1.2.49 to v1.2.50.
Both the nodes kept hanging in a ‘busy updating’ screen for half an hour. After reset the update was unsuccesfull and both nodes booted back in v 1.2.49.

Thank you i not the only one have this, got 5 Tbeam units all 5 rolled back to FW 1.2.49 on meshtastic APP 1.2.52 but may be i go back to APP 1.2.45. Android 7.0 pairing and connecting difficult. Android 10 all seem work fine.

Has something changed. I noticed on the last few alpha and beta releases of the app i can no longer wirelessly update the firmware on my T-Beams or Heltec LORA 32 V2.

1.2.52 has firmware 1.2.50 for the OTA firmware update, tested on a TBeam. what are you seeing different?

it just always fails.
pixel 4a, and pixel 5a both fail with a t-beam and heltec lora32 v2.

tested again on Android 11 and could not replicate (wish it was faster though).

if you can, try to flash device firmware 1.2.48 or 1.2.49 via device-install script and check if the app OTA update is successful then.

this resets all your settings.

hmmm maybe an android 12 problem? both my devices are running 12.

Edit: Just tried on my android 11 pixel 3a and had the same problem. Wireless update failed trying to upgrade from 1.2.45 on t-beam. i submitted a bug log.

Edit2: manually installed 1.2.49 on Heltec Board. app said update successful but the board did not actually update. app said successful instantaneously. Using pixel 5a android 12.

Edit3: retried edit2 with pixel 3a android 11 and got the same result of install successful immediately after pressing the update button but device not actually updated.

good, I see the same 2 exceptions from SoftwareUpdateService:

  • Device rejected filesize
  • Device rejected invalid spiffs partition

this indicates an incompatible partition on the devices.

did you flash using the device-install script?

no, i used ESPHome-Flasher-1.2.0-windows-x64

ok, that explains it. ESPHome will not partition and flash the spiffs.

that would need to flash via command line: ./device-install.bat -f firmware-filename.bin

that requires esptool install. more info here: Flashing ESP32 devices firmware | Meshtastic

looks like you still have an “old” partition style that is now incompatible with .45+ firmware.

@mc-hamster do you know if the firmware OTA update does re-partition device storage?


The old partition scheme stopped being supported by 1.2.1.

Spiffs ota will not recreate the partition table.


It works now, thanks.

1 Like