Can´t set channel name anymore after upgrade to 1.2.50

Hello community,

i just update an already used t-beam with the newest firmware. Before I erased all.
After the flash process it is not possible to set the chanel name.
I used the command:
meshtastic --ch-set name “My Channel” --ch-index 0
I get the confirmation in the command line tool, but at the end it doesn´t change the chanel name.
Other settings like region can be change.

Any idea?


this is a known bug that has been fixed in the next versions, you can upgrade here: Releases · meshtastic/Meshtastic-Android · GitHub

Do you mean it is a bug in android app?
I didn‘t use android, but the cmd in win10.

oh, scratch that. what version of the Python CLI are you using?

python --version
Python 3.9.1

b.t.w. flashing and configuring of several completely new t-beams worked fine. Just my “old”, previoused flashed board, will not accept the name change.

check what you get from: meshtastic --version

latest is 1.2.54

device firmware and the python CLI received a lot of updates recently, check if updating to the latest versions resolve the issue.

I used 1.2.53 and just updated to 1.2.54. But unfortunatelly it still doesn´t work… :frowning:

I use the cmd command:

meshtastic --ch-set name MyName --ch-index 0


Did you already try to factory reset your device ?

meshtastic --set factory_reset 1

After that maybe your namechange is accepted.

No, i did not try this. I actually was not aware of the factory reset possibility.

I thought, that the „erase“ at the beginning of a completely firmware flash delete everything anyway.

I‘ll give it a try.

Mhh, didn´t work.

No Idea how to solve this issue… ???

I tried everything. Even flashing another (already flashed with 1.2.17) tbeam with 1.2.50 via batch-file.
Same issue, so it seems to be a generic issue.

Then I flashed the the “firmware-tbeam-” via ESPHome-Flasher-1.3.0-Windows-x64.exe windows tool.
After that it was possible to change the channel name and every other setting.

As last step I reflashed 1.2.50 via batch-file and again it was not possible to change the channel name.

Something is very strange here.

Is there any possibility to bring a pre-flashed tbeam to a completely factory reset?
Something like “deleteAllcomplete.bin”?

I used the “device-install.bat -f firmware-filename.bin” to flash the devices and that doesn´t work.
After that I just flashed the firmware-tbeam- via ESP tool.

I think the major question is how to get from the old partition to the new one.

I´m wondering if I am the only one having this issue…?!?

very strange. device-install will erase and install a fresh copy of the firmware.

I can confirm changing the channel works on my end after device-install fw 1.2.50 on a tbeam v1.1

1.2.52 is out. check if that makes any changes.

I already tested 1.2.52 yesterday.

Same issue.

Flashing completely fresh boards (mit softrf preinstalled) worked without any problem.


no ideas how to get the partitions fine?