LILYGO TTGO 1.3.40 915MHz Lora32 hardware serial (not USB)

Hi all,

I have the python CLI and flasher utils working fine; I see that I am able to connect to the board via USB serial.

However, what I am trying to do is to connect via GPIO serial - ie. the pins labelled RX and TX (or any two of the other digital pins - I’ve tried configuring several pairs).

I have serial setup on COM3 (USB), with another USB-serial converter running on COM5, under Windows 10.

I currently have serial TX pin set to 28 and RX pin set to 7 (these are as per the docs here - I don’t know if this was just an example or if this is what we’re supposed to use).

This is the result of running meshtastic --post COM3 --info

Module preferences: { "mqtt": {}, "serial": { "enabled": true, "echo": true, "rxd": 7, "txd": 28, "baud": "BAUD_9600" }, "externalNotification": {}, "rangeTest": {}, "telemetry": {}, "cannedMessage": {} }

I am connecting with putty for windows, which usually works well with hardware serial devices, but I cannot get anything working. I have already tried dropping the baud rate to 9600, and I have tried with XON/XOFF and with flow control disabled.

Does anybody have any suggestions, or can perhaps let me know if this type of serial connection is not possible?


Those example pins are going to be different on different hardware, which device are you using?

It’s a LILYGO TTGO, ANZ region (915MHz) - it appears to be this module here:

here’s the closeup; some of the writing on the stickers covering the chips is different, but otherwise all the features appear the same:

Try Rx 35 tx 15 for a tbeam

1 Like

Thanks Garth - tbeam, I’ll remember that!

I notice pins 35 and 15 are broken out/labelled on the PCB, separate from the pins labelled “rx” and “tx”.

So I now have:

Module preferences: { "mqtt": {}, "serial": { "enabled": true, "echo": true, "rxd": 35, "txd": 15, "baud": "BAUD_9600" }, "externalNotification": {}, "rangeTest": {}, "telemetry": {}, "cannedMessage": {} }

and I have connected to pins 35 & 15, still trying. I have tried a FTDI-style USB-serial adapter using the Silicon Labs CP210x driver, and I have tried an arduino with software serial.

Is there anything special I should be sending it? I just try sending keystrokes and looking for echo (I have echo turned on) but I don’t see any data yet.

I got to the same place, filed a bug [Bug]: 1.3 Serial Module Does not work · Issue #1707 · meshtastic/Meshtastic-device · GitHub

1 Like

Thanks Garth! Following with interest.