Heltec Wireless Paper No Display

Recently purchased a couple Heltec Wireless Paper devices using the AliExpress link on the supported devices page. The devices run the included demo software without issue but once the Meshtastic firmware is loaded the display does not work. Nothing is displayed during startup or operation other than the Heltec Automation logo. The devices are otherwise functioning and can be successfully setup using the web-USB-serial interface but still nothing on the screen. Have tried every version of firmware-heltec-wireless-paper-X.X.X.xxxxxxx.bin available using the wipe and reinstall option. Have tried both the ESP32 web installer and the python firmware installer. Is there something I’m missing to get the display working?

Thanks, Jeff – KD8THX

The e-ink display on this device is not supported yet.

Any idea about when the Heltec e-ink display might be supported?

No ETA. Last I heard a device is being sent to one of the developers that has more experience with e-ink displays to see if they could get it going as the developer that implemented the initial support was unable to do so.

1 Like

Have there been any updates on support for the wireless paper? I just got two and the seem nice.

Sorry, there are no updates yet.

Is there an update when the display might be working on the Heltec Paper? Running firmware 2.2.17.dbac2b1

Yes, its working in the latest version.

Sorry its Version 2.2.20.*

Thanks for getting back to me so quickly.

Still no joy. Tried the latest firmware on two different units.

Here’s the details.

Purchased two Heltec Lora Wireless Paper ESP32-S3FN8+SX1262 in August 2023 using the link on the Meshtastic website. https://www.aliexpress.us/item/3256805512013372.html
Both arrived with Heltec demo firmware and the displays worked as intended.
After flashing with the Meshtastic firmware the screen has only the Heltec logo. There is no other screen activity.

Using the online flash utility
https://flasher.meshtastic.org/
Selecting Heltec Wireless Paper
Uploading firmware-2.2.20.f2c04c5.zip
Selecting Full Erase and Install

Is there anything else I should be doing with these to get the display working?

Thanks, Jeff

Unfortunately it currently only works for devices labeled v1.1: HELTEC® LoRa 32 | Meshtastic

That might explain it. I have a big V1.1 sticker on the rear of my boards and all is well.

2.2.20 works on my Paper 1.1. It’s a little “blinky” as if it’s erasing the screen multiple times before writing the update.

Unfortunately the two V1.1 boards I have the display is not working. Tried version 2.2.20 as both upgrade and fresh install. The display remains inactive. The software and device is otherwise working. Both boards run the Heltec display demo software without a problem. Oh well. I’ll keep trying as new firmware versions come out.