Heltec V3 Web Flash failure

Hi Support,

Using a usb a to c data cable, tested it with a mobile phone and it connected correctly

Installed the “CP210x_Universal_Windows_Driver” driver from the Silicon labs website

Windows details
Edition Windows 10 Pro
Version 22H2
Installed on ‎21/‎08/‎2021
OS build 19045.3570
Experience Windows Feature Experience Pack 1000.19052.1000.0

Ran the web firmware flash on both Chrome and Edge and I get the same error, I have tried various different firmware images with the same issue.

I have tried either the reset or program button at the same time as selecting install with no difference

The screen remain blank and the Led is active and windows detects a new device when I plug in the usb

Any suggestions

Ran the CLI the following error is encountered

Is the serial driver an issue?


The program button launches the bootloader when the device is reset. You may want to hold the program button while pressing reset to see if anything changes. But most likely something else is wrong.

If you unplug the device and run the installer, does it report a different error? If it does not, you should check Device Manager to see if the serial converter has the proper drivers. Some boards may have different serial converters; aside from the Silicon Labs CP210x family, WCH serial converters are sometimes used.

Hi All, the board was dead on arrival, I have purchased some new boards and they work as per the instructions

Thank you for your help