Eink Screen on rak4631 does not work

I have typically used nrfutil and the rak4631_eink-ota.zip to install rak FW. I can use the uf2 file drag as well. The nrfutil route has always worked well. Now however if I use this file the installation appears to go ahead without error and I can see the radio in the iOS App. But the eink screen does not function at all (I get the same result with drag and drop using the uf2 file). Using meshtastic --noproto I cannot see any obvious errors. The screen is detected and powered. But the user button does not work, if I message the device it’s acknowledged but no message appears on the screen. This change seems to have occurred sometime after 2.0.3 and 2.1.0 still does not work. So currently all my rak4631/5005 (or 19007) with screens need to run 2.0.3. Does anyone have a method to get the latest rak4631_eink FW to work? Thanks.
Update 10-Mar: I have narrowed the issue of the eink breaking on my 4361/19007 - 2.0.8 is the FW were the break occurs. 2.0.7 works and then at 2.0.8 the eink screen no longer functions. I realise eink screens are not common but does anyone else see this? Is there a way around it? Thanks.