Meshtastic

Dead(almost) ttgo v1.1

SO the screen won’t turn on, tried soldering and everything. Got two devices from banggood. SOldered the displays on both of them. One seems to be working fine, the other one the red led lights up, it reboots (red flashes) and I cn connect it to usb it charges and can also connect to meshtastic script in cmd in windows. This is a log for it :

Microsoft Windows [Version 10.0.19042.1288]
(c) Microsoft Corporation. All rights reserved.

C:\Users\vlad>meshtastic --debug
DEBUG:root:Not logging serial output
DEBUG:root:Connecting to COM6
DEBUG:root:Sending: want_config_id: 3511969903
DEBUG:root:Received myinfo: my_node_num: 84683044 has_gps: true num_bands: 10 region: “1.0-EU865” hw_model_deprecated: “tbeam” firmware_version: “1.0.0” reboot_count: 32 message_timeout_msec: 300000 min_app_version: 172
DEBUG:root:Closing stream
DEBUG:root:Sending: disconnect: true
DEBUG:root:reader is exiting
DEBUG:root:Closing our port

Any ideas what I could do please ? I cant obviously see the bluetooth pairing code cause of the display… could i see that in windows?

if you want to pair via bluetooth without a screen you can double click the middle button on the T-Beams, this sets the pin to the default 123456.

thank you, just found that, it looks like it work work… maybe it s more than just the display not working. it will not reset the bluetooth pass to 123456 for some reason

Also found this by running meshtastic --info

Microsoft Windows [Version 10.0.19042.1288]
(c) Microsoft Corporation. All rights reserved.

C:\Users\vlad>meshtastic --info
Traceback (most recent call last):
File “C:\Users\vlad\AppData\Local\Programs\Python\Python310\lib\runpy.py”, line 196, in run_module_as_main
return run_code(code, main_globals, None,
File “C:\Users\vlad\AppData\Local\Programs\Python\Python310\lib\runpy.py”, line 86, in run_code
exec(code, run_globals)
File "C:\Users\vlad\AppData\Local\Programs\Python\Python310\Scripts\meshtastic.exe_main
.py", line 7, in
File "C:\Users\vlad\AppData\Local\Programs\Python\Python310\lib\site-packages\meshtastic_main
.py", line 663, in main
common()
File "C:\Users\vlad\AppData\Local\Programs\Python\Python310\lib\site-packages\meshtastic_main
.py", line 508, in common
client = SerialInterface(
File “C:\Users\vlad\AppData\Local\Programs\Python\Python310\lib\site-packages\meshtastic_init_.py”, line 936, in init
StreamInterface.init(
File “C:\Users\vlad\AppData\Local\Programs\Python\Python310\lib\site-packages\meshtastic_init_.py”, line 773, in init
self.connect()
File “C:\Users\vlad\AppData\Local\Programs\Python\Python310\lib\site-packages\meshtastic_init_.py”, line 792, in connect
self.startConfig()
File "C:\Users\vlad\AppData\Local\Programs\Python\Python310\lib\site-packages\meshtastic_init
.py", line 480, in _startConfig
self.sendToRadio(startConfig)
File "C:\Users\vlad\AppData\Local\Programs\Python\Python310\lib\site-packages\meshtastic_init
.py", line 495, in _sendToRadio
self.sendToRadioImpl(toRadio)
File "C:\Users\vlad\AppData\Local\Programs\Python\Python310\lib\site-packages\meshtastic_init
.py", line 823, in _sendToRadioImpl
self.writeBytes(header + b)
File "C:\Users\vlad\AppData\Local\Programs\Python\Python310\lib\site-packages\meshtastic_init
.py", line 810, in _writeBytes
self.stream.flush()
File “C:\Users\vlad\AppData\Local\Programs\Python\Python310\lib\site-packages\serial\serialwin32.py”, line 345, in flush
while self.out_waiting:
File “C:\Users\vlad\AppData\Local\Programs\Python\Python310\lib\site-packages\serial\serialwin32.py”, line 447, in out_waiting
raise SerialException(“ClearCommError failed ({!r})”.format(ctypes.WinError()))
serial.serialutil.SerialException: ClearCommError failed (OSError(9, ‘The handle is invalid.’, None, 6))

C:\Users\vlad>

I double clicked middle button to set pin to 123456 but it sais pair failed still on meshtastic, how do i double press middle button? soon as its on while blue led blinks? when as oled not working, also how can i tell if the firmware is on properly if its visable via ble does that mean it has firmwere?

im using 1.1 and nothing comes on oled display making me think it needs re flashing but cant find a link to it so i can try reflashing.

omfg no support anywhere no1 replies yt discord ali express this site nowhere where the fk are the ppl!?!¬? ffs help plz!

does meshtastic --info run fine on the other working device?

that debug msg firmware_version: “1.0.0” looks odd. did you flash the firmware yourself?

you can try to re-flash using device-install.bat (requires esptool). if both devices are identical and this also fails on only one of them, theres not much more to do unfortunately.

thank you AndreK, yes meshtastic --info runs fine on the other one. i will try to reflash , thanks a lot for the reply!

forgot to say, i did not install firmware myself they are both as they came from bangood

So after flashing the firmware as instructed it now appears to be working fine. I took the display off and use it like that, i think when i desoldered it i might have stripped some of the connections on the pcb so don’t know if it will work again when i solder it back on, but at least the unit works.Thank you AndreK

1 Like

I also seem to have bricked(?) my T-beam. I got my t-beam from banggood. Seems 1.0.0 version was preinstalled. Display was doing great - red led and blue leds blinking well with 1.0.0

Then I used esptool to update to firmware-tbeam-1.2.45.b674054.bin
Result: OLED is not coming on, a tiny red LED blinks. Blue LED is not blinking.

I looked around, folks seem to be happy with this version.

Something I am missing?

[ output from meshtastic --info ]
Connected to radio

Owner: Unknown 4e4c (?4C)

My info: { “myNodeNum”: 4066790988, “hasGps”: true, “numBands”: 13, “firmwareVersion”: “1.2.45.b674054”, “errorCode”: “NoAXP192”, “errorAddress”: 470, “errorCount”: 2, “rebootCount”: 2, “messageTimeoutMsec”: 300000, “minAppVersion”: 20200, “maxChannels”: 8 }

Nodes in mesh:
{‘num’: 4066790988, ‘user’: {‘id’: ‘!f2664e4c’, ‘longName’: ‘Unknown 4e4c’, ‘shortName’: ‘?4C’, ‘macaddr’: ‘CDryZk5M’, ‘hwModel’: ‘TBEAM’}, ‘position’: {}, ‘lastHeard’: 1636927554}

Preferences: { “phoneTimeoutSecs”: 900, “lsSecs”: 300 }

Channels:
PRIMARY psk=default { “modemConfig”: “Bw125Cr48Sf4096”, “psk”: “AQ==” }

Primary channel URL: https://www.meshtastic.org/d/#CgUYAyIBAQ

[Update]
Looked at the “meshtastic --info” output. It says ‘noAXP192’. So I tried firmware 0.7-1.2.45.
Still no luck.

[ More info]
Prior to upgrading firmware, I could connect using BLE scanner and was able to see the services, read/write characteristics. Now after upgrade to 1.2.45 - the BLE scan shows my device - but cannot connect to the device.

I purchased two units, One worked and the other no screen - ReFlashed the one that didnt work now ok…