Changing language in the Android app has no effect

Running Android 13 here with the latest Meshtastic app from the play store.
Changing the app’s language has no effect, at all.

Is this expected or is this just happening on my phone?
I cleared the app’s data and even reinstalled it but nothing happened.

Just tested on two different A13 devices and it worked without issue for me. Changed to several different languages and everything was update.

Just noticed it’s the beta version from the Play Store. Does that make a difference?

One of my devices is on a beta version and the other the latest alpha

I can confirm that it’s only happening on the beta version from the Play Store. The regular version does not have this problem.

Yeah, I had the beta version manually installed from GitHub, to the play store but just did and it does indeed not want to change the language from the play store, even though it does when using the same version apk I downloaded from GitHub. Weird. But it works in the release before and the current alpha release. I would say wait until the next version and it should be resolved.

Hi everyone, just tested the latest update 2.2.8 in the About, android 10, the language choice has no effect. It remains displaying everything in English, even if the chosen language is displayed correctly in the selector. Tried adding new keyboards, language in Android, no changes, the issue remains. Thanks, SB.

Is this installed from the Play Store or Github?

Hi Kokroo, I installed it from Play Store. Tried also on Android 7, same issue, tested on Android 11, it works. So, probably related to the way the call is done to change the language, or to the Android versions supported >=11.