Meshtastic

Caution-How to Brick a tbeam sx1262-neo m8n

I received my first of new model sx1262.
It booted fine to SoftRf
I loaded firmware 0.9.3

  1. The oled was intermittent blank and the meshtastic splash
  2. The blue light on if battery is installed
  3. reboots sometimes blanked the screen permanently
  4. the gps light sometime turned on

So loaded firmware 0.9.1

  1. It again was intermittant on the screen
  2. I installed a battery… and it crashed
  3. rebooted two or three times and the meshtastic splash came back
  4. on reset; serial port said no gps, no radio
  5. took it outside and after 20 minutes it had 5 sats
  6. cycled it with reset,… took less the 5 seconds to get 4 sats

Then… powered it off… waited an hour…“tried” to power it on… no joy
It has a weak red light next to processor, the gps led flashes every minute
the blue light illuminates if battery is installed
Now. esphome can’t talk to the board, putty only shows ▒▒ character every second

q.? Does anyone know to interrupt the running program and force it into factory mode ?
and what baud rates to try ?

Don’t worry, your TTGO is not bricked.
I am sure that your computer will have created some conflict with the serial port, if you restart the computer and connect the TTGO again It is recognized by the serial port without problems, I advise you to install the right driver
I do not recommend using the Windows stock ones.
Returning to PUTTY the speed to use is 921600 not 9600.

Try to flash 9.3 firmware in 9.3 it seems they have solved the gps problem.

1 Like

Well I tried those ideas…
using https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers

Same results, I also tried the trick of shorting the leads for gps battery backup

It could be the windows device driver does not support 921600 via usb, see attached screen shot, but putty allow me to enter the value. And that works for other tbeams to get the ble pairing codes needed to interface with android app.

1 Like

No luck, I killed the uart somehow. port is recognized, but can’t connect
esptool.py v2.6
Serial port COM8
Connecting……_____

A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header
A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header

1 Like

If you have problems with the ttgo that is no longer known in the com port after a failed flash or for unknown reasons, or giving an error when the “esphomeflasher” creates a write error in the ttgo memory
You have to clear its memory with “ESP32 Download Tool” then you have to unplug the TTGO and plug it back into the computer again and you have to flash the meshtastic firmware again
Restart the PC if necessary.

1 Like

I hope this is normal… it;s been sync for over 30 minutes

that can also happen if you still have the serial port open in another thread.

2 Likes

Also try a baud rate of 115200 as I think that is the ESP32 default. Meshtastic requires 921600.

Good point, I was watching the log screen as the esp32 “tool” was attempting to negotiating a response from my bricked tbeam and it started at 921600 then in the 400000, finally sticking to 115200.

Bottom line, it could never get “chip” information out my device, too bad. Something running on my device preventing a serial packet to be sent out. I hooked up a serial comm’s analyzer where I can send and receive data, it seems to only accept one HEX character/word into it’s com port with no buffering, and slowly just sends out fc, fe, ff useless characters.