Can't get android app to recognize T-beam

Samsung Android 12
Meshtastic 1.2.67
T-beam 1.3.40

Android throws an app is needed to use this device

Have you installed meshtastic from google store ? EDIT: just saw that you have version mismatch. 1.2 <> 1.3. those are incompatible see
Releases ยท meshtastic/Meshtastic-Android ยท GitHub

Uninstalled then installed 1.3.40 APK, but no dice