Meshtastic

"Brownout" (and does not start)

Since this evening, my T-Beam v1.1 (running firmware 1.1.33) does not start anymore.

The red LED starts glowing for a second and then turns off. The last couple of messages on the serial line are here:

SRC REG:0xc4
Charging enable is enable
Charging target-voltage : 0x2
end when the charge cure
A
0
00:00:00 Read RTC time as 0 (cur millis 188) quality=0
00:00:00 WANT GPS=1
00:00:00 Setting GPS power=1
00:00:00 Connected to UBLOX GPS successfully

Brownout

…and that’s it.

This happens with or without a battery (blue LED glowing, indicating charging).
I also cannot connect using esptool (“connection timed out”) to read out chip_id or anything, making this one a nice brick. :unamused:

Any idea what’s going on? This T-Beam worked perfectly before.

the brownout detector is part of the CPU (that we enable, but really it is important) that checks for low voltage to the CPU. If that happens it freaks out and resets it (to avoid running nondeterministically). Something has broken on that board with the power delivery to the CPU.

After unsoldering the screen, the TBeam starts up again.
Sadly, the serial console now outputs

NOTE! Recording critical error 6, address=0

So, the axp192 is shot. :unamused:

2 Likes

Ive been meaning to buy a solder rework station and give this a try too. I fried mine directly applying 12v to it.

Dont do that :laughing:

Axp192 - Ebay

1 Like

1 of my 4 has the red LED come on then starts flickering on & off regularly at about half a second intervals. 90% sure it worked when I soldered on the screen. My solution has been to ignore it & mess with the other 3 for now.