Very strange problem with T-Echo, reset leads to undefined state

Hey all,

I became aware of Meshtastic via an article in German computer magazine c’t: Katastrophennetz zum Eigenbau | c't | Heise Magazine (unfortunately, behind a paywall)

Anyway, I got myself a pair of T-Echo and set them up, with firmware 1.2.65. Everything was working fine for a while. But after a few hours I ran into a very strange problem. One of the two T-Echo shows the strangest behaviour:

When hitting the reset button, it goes into some kind of undefined state. The left LED is then pulsing continuously. It seems non-responsive to any further button presses. It seems to continue to send and receive messages and communicate with my android phone, though, which is rather strange.

When connecting it to a computer via USB, it will show the drive to flash a firmware.

I can get it working normally again by flashing an older firmware, say 1.2.60 – it will take it but not reboot and continue in the undefined state. Pressing reset again will mount the drive for another firmware flash. When then I flash 1.2.65 it will reboot and behave beautifully normal. But only until I hit the reset button the next time, which will make the whole thing go again. Oh, and the firmware downgrade is mandatory, without it, just trying to reflash 1.2.65, will not leave the undefined state.

So what is going wrong here? Why is this happening on one but not the other device? Disconnecting the battery will also not recover from the strange state.

Any help appreciated! Let me know if I should test something, will happily do so.


Small addition: A “meshtastic --reboot” will lead to the same undefined state. A “meshtastic --set factory_reset 1” works fine and initiates a proper reboot repeatedly. Still, next time hitting the reset button will screw things up.

this could be due to file corruption. try to format your file system using this .uf2 file: nRF52_Internal_Format/Meshtastic_nRF52_factory_erase.uf2 at main · markbirss/nRF52_Internal_Format · GitHub

before you transfer the file, make sure you are able to connect a serial monitor to the device, you will need it to send a key press.

1 Like

Thanks Andre for the quick reply - it worked! Brilliant support!

For what it’s worth, I tried first using tio under Linux but the drivers would not compile under kernel 5.15. I then used MobaXterm under Windows to connect to the serial port (check device manager to find out com port).

1 Like