T-Echo maybe bricked?

Hi All,

Tried updating to latest 1.3.39 on my t-echo today, and it looked all fine until i set the region, it rebooted a few times, but now seems to be stuck in a reboot loop.

I’ve tried re-flashing it, but end up with the same issue.

Here’s what I see on the serial console:

[tio 15:56:02] Disconnected
[tio 15:56:04] Connected
H??:??:?? 1

//\ E S H T /\ S T / C

??:??:?? 1 Filesystem files:
??:??:?? 1    (-4 Bytes)

[tio 15:56:04] Disconnected
[tio 15:56:06] Connected
H??:??:?? 1

//\ E S H T /\ S T / C

??:??:?? 1 Filesystem files:
??:??:?? 1    (-4 Bytes)
[tio 15:56:06] Disconnected

Use my uf2 file to erase your device, and flash metastatic again

tio terminal can be replaced with another serial terminal application

2 Likes

Gave that a try, but it didn’t reboot after dropping the file onto it.
It happily reboots when I drop the meshtastic firmware onto it, but still sits in a boot loop.

How you determine if it reboot or not ?
Nothing showing on your serial terminal app ?

Tio will show Disconnected and Connected message as below after you copied erase file

Possibly corrupt download ?

Check the MD5SUM of your downloaded “Meshtastic_nRF52_factory_erase.uf2”

md5sum Meshtastic_nRF52_factory_erase.uf2 
6f634aed38d276039b89ac6214de7108  Meshtastic_nRF52_factory_erase.uf2
1 Like

Yep, nothing in terminal app, no Disconnect/reconnect.

hmm actually looks like the md5 doesn’t match, I’ll try and download it again.

Thanks!

This was it, thanks heaps!

Great, you are welcome

1 Like