Meshtastic

Very low Range [Heltec LoRa 32]

Hi Guys,

I have 3 of this [Heltec LoRa 32] boards.
I have ordered the 868 version (UK) but I received with 915MHz antenna.
So I’m not 100% sure if the hardware is different or it is just replace the antenna and set up the settings.
The chip is SX1276 / 1810 / 177906
I have tried all frequencies but the range is not longer than a few meters.
Can you help me to debug the problem.

Thank you in advance,
Antonio Reis

.

LOG:

??:??:?? 0 Filesystem files:
??:??:?? 0 /prefs/db.proto
??:??:?? 0 /prefs/radio.proto
??:??:?? 0 /prefs/channels.proto
??:??:?? 0 I2C device found at address 0x3c
??:??:?? 0 ssd1306 display found
??:??:?? 0 done
??:??:?? 0 Meshtastic hwvendor=5, swver=1.2.17, hwver=1.0
??:??:?? 0 Setting random seed 889865241
??:??:?? 0 Total heap: 255884
??:??:?? 0 Free heap: 221652
??:??:?? 0 Total PSRAM: 0
??:??:?? 0 Free PSRAM: 0
??:??:?? 0 NVS: UsedEntries 84, FreeEntries 546, AllEntries 630
??:??:?? 0 Setup Preferences in Flash Storage
??:??:?? 0 Number of Device Reboots: 230
??:??:?? 0 Initial packet id 1412172530, numPacketId 4294967295
??:??:?? 0 Setting default channel and radio preferences!
??:??:?? 0 Expanding short PSK #1
??:??:?? 0 Wanted region 0, using Unset
??:??:?? 0 Loading /prefs/db.proto
??:??:?? 0 Loaded saved preferences version 11
??:??:?? 0 Loading /prefs/radio.proto
??:??:?? 0 Loading /prefs/channels.proto
??:??:?? 0 Number of Device Reboots: 230
??:??:?? 0 Expanding short PSK #1
??:??:?? 0 Wanted region 1, using US
??:??:?? 0 region=1, NODENUM=0xc40cdd6c, dbsize=3
??:??:?? 0 Read RTC time as 0 (cur millis 91) quality=0
??:??:?? 0 WANT GPS=1
??:??:?? 0 Setting GPS power=1
??:??:?? 2 ERROR: No UBLOX GPS found
??:??:?? 2 Hoping that NMEA might work
??:??:?? 2 WANT GPS=1
??:??:?? 2 External Notification Plugin Disabled
??:??:?? 2 Turning on screen
??:??:?? 2 Starting meshradio init…
??:??:?? 2 (bw=125, sf=12, cr=4/8) packet symLen=32 ms, payloadSize=16, time 2269 ms
??:??:?? 2 Set radio: name=LongSlow, config=3, ch=0, power=0
??:??:?? 2 Radio myRegion->freq: 903.080017
??:??:?? 2 Radio myRegion->spacing: 2.160000
??:??:?? 2 Radio myRegion->numChannels: 13
??:??:?? 2 Radio channel_num: 0
??:??:?? 2 Radio frequency: 903.080017
??:??:?? 2 Short packet time: 2269 msec
??:??:?? 2 Set radio: final power level=17
??:??:?? 2 RF95 init result 0
??:??:?? 2 Radio init succeeded, using RF95 radio
??:??:?? 2 PowerFSM init, USB power=1
[D][esp32-hal-cpu.c:189] setCpuFrequencyMhz(): PLL: 320 / 4 = 80 Mhz, APB: 80000000 Hz
??:??:?? 2 [Screen] Screen: Started…
??:??:?? 2 [GPS] publishing GPS lock=0
??:??:?? 2 [GPS] No GPS lock
??:??:?? 2 [GPS] got gps notify time=0, lat=0, bat=0
??:??:?? 2 [GPS] DB update position node=0xc40cdd6c time=0, latI=0, lonI=0
??:??:?? 2 [GPS] Node status update: 3 online, 3 total
??:??:?? 2 [SerialPlugin] Serial Plugin Disabled
??:??:?? 2 [StoreForwardPlugin] Store & Forward Plugin - Disabled
??:??:?? 2 [RangeTestPlugin] Range Test Plugin - Disabled
Transition powerFSM transition=boot timeout, from=BOOT to=POWER
??:??:?? 5 [PowerFSM] Setting bluetooth enable=1
Pre BT: 210836 heap size
??:??:?? 5 [PowerFSM] Starting bluetooth
??:??:?? 5 [Screen] Done with boot screen…
??:??:?? 5 [Screen] Screen: Powered…
??:??:?? 5 [Screen] showing standard frames
??:??:?? 5 [Screen] Showing 0 plugin frames
??:??:?? 5 [Screen] Total frame count: 35
??:??:?? 5 [Screen] Added plugins. numframes: 0
??:??:?? 5 [Screen] Finished building frames. numframes: 5
??:??:?? 5 [Screen] Setting fast framerate
??:??:?? 6 [Screen] BLE task running
??:??:?? 6 [Screen] registered service 0x1800 with handle=1
??:??:?? 6 [Screen] registered service 0x1801 with handle=6
??:??:?? 6 [Screen] registered service 6ba1b218-15a8-461f-9fa8-5dcae273eafd with handle=10
??:??:?? 6 [Screen] registered service cb0b9a0b-a84c-4c0d-bdbb-442e3144ee30 with handle=18
[D][esp32-hal-i2c.c:1345] i2cProcQueue(): Gross Timeout Dead start=0x1799, end=0x1799, =0, max=50 error=1
[E][esp32-hal-i2c.c:318] i2cDumpI2c(): i2c=0x3ffbe2c8
[I][esp32-hal-i2c.c:319] i2cDumpI2c(): dev=0x60013000 date=0x16042000
[I][esp32-hal-i2c.c:321] i2cDumpI2c(): lock=0x3ffbc234
[I][esp32-hal-i2c.c:323] i2cDumpI2c(): num=0
[I][esp32-hal-i2c.c:324] i2cDumpI2c(): mode=1
[I][esp32-hal-i2c.c:325] i2cDumpI2c(): stage=3
[I][esp32-hal-i2c.c:326] i2cDumpI2c(): error=1
[I][esp32-hal-i2c.c:327] i2cDumpI2c(): event=0x3ffbad6c bits=10
[I][esp32-hal-i2c.c:328] i2cDumpI2c(): intr_handle=0x3ffbc294
[I][esp32-hal-i2c.c:329] i2cDumpI2c(): dq=0x3ffd907c
[I][esp32-hal-i2c.c:330] i2cDumpI2c(): queueCount=1
[I][esp32-hal-i2c.c:331] i2cDumpI2c(): queuePos=0
[I][esp32-hal-i2c.c:332] i2cDumpI2c(): errorByteCnt=2
[I][esp32-hal-i2c.c:333] i2cDumpI2c(): errorQueue=0
[I][esp32-hal-i2c.c:334] i2cDumpI2c(): debugFlags=0x00000000
[I][esp32-hal-i2c.c:311] i2cDumpDqData(): Debug Buffer not Enabled
[I][esp32-hal-i2c.c:354] i2cDumpInts(): Debug Buffer not Enabled
??:??:?? 6 [Screen] BLE advertisting type=0, Private=0, Device Address: 15:fc:f5:c4:0c:dd

??:??:?? 6 [Screen] Setting idle framerate
??:??:?? 14 connection established; status=0 handle=0 our_ota_addr_type=0 our_ota_addr=01:fc:f5:c4:0c:dd
our_id_addr_type=0 our_id_addr=01:fc:f5:c4:0c:dd
peer_ota_addr_type=1 peer_ota_addr=00:c1:e7:27:1f:33
peer_id_addr_type=1 peer_id_addr=00:c1:e7:27:1f:33
conn_itvl=40 conn_latency=0 supervision_timeout=1280 encrypted=0 authenticated=0 bonded=0
??:??:?? 15
??:??:?? 15 encryption change event; status=0 handle=0 our_ota_addr_type=0 our_ota_addr=01:fc:f5:c4:0c:dd
our_id_addr_type=0 our_id_addr=01:fc:f5:c4:0c:dd
peer_ota_addr_type=1 peer_ota_addr=00:c1:e7:27:1f:33
peer_id_addr_type=1 peer_id_addr=00:c1:e7:27:1f:33
conn_itvl=40 conn_latency=0 supervision_timeout=1280 encrypted=1 authenticated=1 bonded=1
??:??:?? 15
??:??:?? 15 subscribe event; conn_handle=0 attr_handle=16 reason=3 prevn=0 curn=1 previ=0 curi=0
??:??:?? 18 mtu update event; conn_handle=0 cid=4 mtu=512
??:??:?? 19 BLE fromRadio called omlen=1, ourlen=0
??:??:?? 19 Client wants config, nonce=200
??:??:?? 19 Reset nodeinfo read pointer
??:??:?? 19 getFromRadio, state=2
??:??:?? 19 BLE fromRadio called omlen=1, ourlen=33
??:??:?? 19 getFromRadio, state=3
??:??:?? 19 Sending nodeinfo: num=0xc40cdd6c, lastseen=0, id=!c40cdd6c, name=Mobile
??:??:?? 19 BLE fromRadio called omlen=1, ourlen=58
??:??:?? 19 getFromRadio, state=3
??:??:?? 19 Sending nodeinfo: num=0xc40ce268, lastseen=1617238198, id=!c40ce268, name=Head Quarter
??:??:?? 19 BLE fromRadio called omlen=1, ourlen=78
??:??:?? 19 getFromRadio, state=3
??:??:?? 19 Sending nodeinfo: num=0xabf96290, lastseen=1617238532, id=!abf96290, name=Home
??:??:?? 19 BLE fromRadio called omlen=1, ourlen=74
??:??:?? 20 getFromRadio, state=3
??:??:?? 20 Done sending nodeinfos
??:??:?? 20 getFromRadio, state=4
??:??:?? 20 BLE fromRadio called omlen=1, ourlen=3
??:??:?? 20 BLE fromRadio called omlen=1, ourlen=0
??:??:?? 20 PACKET FROM PHONE (id=0xe27fa338 Fr0x6c To0x6c, WantAck1, HopLim0 Ch0x0 Portnum=6 WANTRESP priority=70)
??:??:?? 20 Warning: phone tried to pick a nodenum, we don’t allow that.
??:??:?? 20 [Router] Enqueued local (id=0xe27fa338 Fr0x00 To0x6c, WantAck1, HopLim0 Ch0x0 Portnum=6 WANTRESP priority=70)
??:??:?? 20 [Router] Received routing from=0xc40cdd6c, id=0x542c0af5, portnum=6, payloadlen=9
??:??:?? 20 [Router] Routing sniffing (id=0x542c0af5 Fr0x6c To0x6c, WantAck0, HopLim3 Ch0x0 Portnum=6 requestId=e27fa338 priority=70)
??:??:?? 20 [Router] FIXME not implemented addRoute
??:??:?? 20 [Router] Received a ack for 0xe27fa338, stopping retransmissions
??:??:?? 20 [Router] FIXME-update-db Sniffing packet
??:??:?? 20 [Router] Delivering rx packet (id=0x542c0af5 Fr0x6c To0x6c, WantAck0, HopLim3 Ch0x0 Portnum=6 requestId=e27fa338 priority=70)
??:??:?? 20 [Router] Forwarding to phone (id=0x542c0af5 Fr0x6c To0x6c, WantAck0, HopLim3 Ch0x0 Portnum=6 requestId=e27fa338 priority=70)
??:??:?? 20 [Router] Update DB node 0xc40cdd6c, rx_time=0
??:??:?? 20 [Router] Plugin routing considered
??:??:?? 20 Telling client we have new packets 1
??:??:?? 20 BLE notify fromNum
??:??:?? 20 BLE reading a uint32
??:??:?? 20 getFromRadio, state=5
??:??:?? 20 phone downloaded packet (id=0x542c0af5 Fr0x6c To0x6c, WantAck0, HopLim3 Ch0x0 Portnum=6 requestId=e27fa338 priority=70)
??:??:?? 20 BLE fromRadio called omlen=1, ourlen=41
??:??:?? 20 BLE fromRadio called omlen=1, ourlen=0
??:??:?? 20 PACKET FROM PHONE (id=0xe27fa339 Fr0x6c To0x6c, WantAck1, HopLim0 Ch0x0 Portnum=6 WANTRESP priority=70)
??:??:?? 20 Warning: phone tried to pick a nodenum, we don’t allow that.
??:??:?? 20 [Router] Enqueued local (id=0xe27fa339 Fr0x00 To0x6c, WantAck1, HopLim0 Ch0x0 Portnum=6 requestId=e27fa339 priority=70)
??:??:?? 20 getFromRadio, state=5
??:??:?? 20 phone downloaded packet (id=0x542c0af6 Fr0x6c To0x6c, WantAck0, HopLim3 Ch0x0 Portnum=6 requestId=e27fa339 priority=70)
??:??:?? 20 BLE fromRadio called omlen=1, ourlen=43
??:??:?? 20 BLE fromRadio called omlen=1, ourlen=0
??:??:?? 21 PACKET FROM PHONE (id=0xe27fa33a Fr0x6c To0x6c, WantAck1, HopLim0 Ch0x0 Portnum=6 WANTRESP priority=70)
??:??:?? 21 Warning: phone tried to pick a nodenum, we don’t allow that.
??:??:?? 21 [Router] Enqueued local (id=0xe27fa33a Fr0x00 To0x6c, WantAck1, HopLim0 Ch0x0 Portnum=6 requestId=e27fa33a priority=70)
??:??:?? 21 getFromRadio, state=5
??:??:?? 21 phone downloaded packet (id=0x542c0af7 Fr0x6c To0x6c, WantAck0, HopLim3 Ch0x0 Portnum=6 requestId=e27fa33a priority=70)
??:??:?? 21 BLE fromRadio called omlen=1, ourlen=38
??:??:?? 21 BLE fromRadio called omlen=1, ourlen=0
??:??:?? 25 PACKET FROM PHONE (id=0xe27fa33b Fr0x6c To0xff, WantAck1, HopLim0 Ch0x0 Portnum=1)
??:??:?? 25 Warning: phone tried to pick a nodenum, we don’t allow that.
??:??:?? 25 handleReceived (id=0xe27fa33b Fr0x00 To0xff, WantAck1, HopLim0 Ch0x0 Portnum=1)
??:??:?? 25 Received text msg from=0x0, id=0xe27fa33b, msg=are you there?
??:??:?? 25 showing standard frames
??:??:?? 25 Showing 0 plugin frames
??:??:?? 25 Total frame count: 35
??:??:?? 25 Added plugins. numframes: 0
??:??:?? 25 Finished building frames. numframes: 5
??:??:?? 25 Setting fast framerate
??:??:?? 25 Plugin text considered
??:??:?? 25 External Notification Plugin Disabled
??:??:?? 25 [Screen] Plugin ExternalNotificationPlugin considered
??:??:?? 25 [Screen] Plugin ExternalNotificationPlugin handled and skipped other processing
??:??:?? 25 [Screen] Setting next retransmission in 21663 msecs: (id=0xe27fa33b Fr0x00 To0xff, WantAck1, HopLim3 Ch0x0 Portnum=1)
??:??:?? 25 [Screen] Adding packet record (id=0xe27fa33b Fr0x00 To0xff, WantAck1, HopLim3 Ch0x0 Portnum=1)
??:??:?? 25 [Screen] Expanding short PSK #1
??:??:?? 25 [Screen] Installing AES128 key!
??:??:?? 25 [Screen] enqueuing for send (id=0xe27fa33b Fr0x6c To0xff, WantAck0, HopLim3 Ch0xb1 encrypted)
??:??:?? 25 [Screen] (bw=125, sf=12, cr=4/8) packet symLen=32 ms, payloadSize=34, time 3219 ms
??:??:?? 25 [Screen] txGood=0,rxGood=0,rxBad=0
??:??:?? 25 [Screen] AirTime - Packet transmitted : 3219ms
??:??:?? 25 [Screen] Setting idle framerate
??:??:?? 26 [RadioIf] Starting low level send (id=0xe27fa33b Fr0x6c To0xff, WantAck0, HopLim3 Ch0xb1 encrypted priority=64)
??:??:?? 30 [RadioIf] Completed sending (id=0xe27fa33b Fr0x6c To0xff, WantAck0, HopLim3 Ch0xb1 encrypted priority=64)
??:??:?? 32 [NodeInfoPlugin] Sending our nodeinfo to mesh (wantReplies=1)
??:??:?? 32 [NodeInfoPlugin] sending owner !c40cdd6c/Mobile/Mbl
??:??:?? 32 [NodeInfoPlugin] Update DB node 0xc40cdd6c, rx_time=0
??:??:?? 32 [NodeInfoPlugin] handleReceived (id=0x542c0af8 Fr0x6c To0xff, WantAck0, HopLim3 Ch0x0 Portnum=4 WANTRESP priority=10)
??:??:?? 32 [NodeInfoPlugin] Received nodeinfo from=0xc40cdd6c, id=0x542c0af8, portnum=4, payloadlen=34
??:??:?? 32 [NodeInfoPlugin] old user !c40cdd6c/Mobile/Mbl
??:??:?? 32 [NodeInfoPlugin] updating changed=0 user !c40cdd6c/Mobile/Mbl
??:??:?? 32 [NodeInfoPlugin] Plugin nodeinfo considered
??:??:?? 32 [NodeInfoPlugin] Received routing from=0xc40cdd6c, id=0x542c0af8, portnum=4, payloadlen=34
??:??:?? 32 [NodeInfoPlugin] Routing sniffing (id=0x542c0af8 Fr0x6c To0xff, WantAck0, HopLim3 Ch0x0 Portnum=4 WANTRESP priority=10)
??:??:?? 32 [NodeInfoPlugin] FIXME-update-db Sniffing packet
??:??:?? 32 [NodeInfoPlugin] Delivering rx packet (id=0x542c0af8 Fr0x6c To0xff, WantAck0, HopLim3 Ch0x0 Portnum=4 WANTRESP priority=10)
??:??:?? 32 [NodeInfoPlugin] Forwarding to phone (id=0x542c0af8 Fr0x6c To0xff, WantAck0, HopLim3 Ch0x0 Portnum=4 WANTRESP priority=10)
??:??:?? 32 [NodeInfoPlugin] Update DB node 0xc40cdd6c, rx_time=0
??:??:?? 32 [NodeInfoPlugin] Plugin routing considered
??:??:?? 32 [NodeInfoPlugin] No one responded, send a nak
??:??:?? 32 [NodeInfoPlugin] Alloc an err=8,to=0xc40cdd6c,idFrom=0x542c0af8,id=0x542c0af9
??:??:?? 32 [NodeInfoPlugin] Enqueued local (id=0x542c0af9 Fr0x6c To0x6c, WantAck0, HopLim0 Ch0x0 Portnum=5 requestId=542c0af8 priority=120)
??:??:?? 32 [NodeInfoPlugin] Adding packet record (id=0x542c0af8 Fr0x6c To0xff, WantAck0, HopLim3 Ch0x0 Portnum=4 WANTRESP priority=10)
??:??:?? 32 [NodeInfoPlugin] Expanding short PSK #1
??:??:?? 32 [NodeInfoPlugin] Installing AES128 key!
??:??:?? 32 [NodeInfoPlugin] enqueuing for send (id=0x542c0af8 Fr0x6c To0xff, WantAck0, HopLim3 Ch0xb1 encrypted priority=10)
??:??:?? 32 [NodeInfoPlugin] (bw=125, sf=12, cr=4/8) packet symLen=32 ms, payloadSize=56, time 4366 ms
??:??:?? 32 [NodeInfoPlugin] txGood=1,rxGood=0,rxBad=0
??:??:?? 32 [NodeInfoPlugin] AirTime - Packet transmitted : 4366ms
??:??:?? 32 Telling client we have new packets 4
??:??:?? 32 BLE notify fromNum
??:??:?? 32 BLE reading a uint32
??:??:?? 32 [Router] Adding packet record (id=0x542c0af9 Fr0x6c To0x6c, WantAck0, HopLim0 Ch0x0 Portnum=5 requestId=542c0af8 priority=120)
??:??:?? 32 [Router] handleReceived (id=0x542c0af9 Fr0x6c To0x6c, WantAck0, HopLim0 Ch0x0 Portnum=5 requestId=542c0af8 priority=120)
??:??:?? 32 [Router] Received routing from=0xc40cdd6c, id=0x542c0af9, portnum=5, payloadlen=2
??:??:?? 32 [Router] Routing sniffing (id=0x542c0af9 Fr0x6c To0x6c, WantAck0, HopLim0 Ch0x0 Portnum=5 requestId=542c0af8 priority=120)
??:??:?? 32 [Router] FIXME not implemented addRoute
??:??:?? 32 [Router] FIXME not implemented removeRoute
??:??:?? 32 [Router] Received a nak for 0x542c0af8, stopping retransmissions
??:??:?? 32 [Router] FIXME-update-db Sniffing packet
??:??:?? 32 [Router] Delivering rx packet (id=0x542c0af9 Fr0x6c To0x6c, WantAck0, HopLim0 Ch0x0 Portnum=5 requestId=542c0af8 priority=120)
??:??:?? 32 [Router] Forwarding to phone (id=0x542c0af9 Fr0x6c To0x6c, WantAck0, HopLim0 Ch0x0 Portnum=5 requestId=542c0af8 priority=120)
??:??:?? 32 [Router] Update DB node 0xc40cdd6c, rx_time=0
??:??:?? 32 [Router] Plugin routing considered
??:??:?? 32 [Screen] Screen: Joined: Mobile
??:??:?? 32 Telling client we have new packets 5
??:??:?? 32 BLE notify fromNum
??:??:?? 32 BLE reading a uint32
??:??:?? 32 getFromRadio, state=5
??:??:?? 32 phone downloaded packet (id=0x542c0af8 Fr0x6c To0xff, WantAck0, HopLim3 Ch0x0 Portnum=4 WANTRESP priority=10)
??:??:?? 32 BLE fromRadio called omlen=1, ourlen=63
??:??:?? 32 getFromRadio, state=5
??:??:?? 32 phone downloaded packet (id=0x542c0af9 Fr0x6c To0x6c, WantAck0, HopLim0 Ch0x0 Portnum=5 requestId=542c0af8 priority=120)
??:??:?? 32 BLE fromRadio called omlen=1, ourlen=32
??:??:?? 32 BLE fromRadio called omlen=1, ourlen=0
??:??:?? 32 BLE fromRadio called omlen=1, ourlen=0
??:??:?? 33 [RadioIf] Can not send yet, busyRx
??:??:?? 34 [RadioIf] Can not send yet, busyRx
??:??:?? 34 [RadioIf] Can not send yet, busyRx
??:??:?? 34 [RadioIf] Can not send yet, busyRx
??:??:?? 35 [RadioIf] (bw=125, sf=12, cr=4/8) packet symLen=32 ms, payloadSize=34, time 3219 ms
??:??:?? 35 [RadioIf] Lora RX (id=0xe27fa33b Fr0x6c To0xff, WantAck0, HopLim2 Ch0xb1 encrypted rxSNR=10.25)
??:??:?? 35 [RadioIf] AirTime - Packet received : 3219ms
??:??:?? 35 [Router] Rx someone rebroadcasting for us (id=0xe27fa33b Fr0x6c To0xff, WantAck0, HopLim2 Ch0xb1 encrypted rxSNR=10.25)
??:??:?? 35 [Router] generating implicit ack
??:??:?? 35 [Router] Alloc an err=0,to=0xc40cdd6c,idFrom=0xe27fa33b,id=0x542c0afa
??:??:?? 35 [Router] Enqueued local (id=0x542c0afa Fr0x6c To0x6c, WantAck0, HopLim0 Ch0x0 Portnum=5 requestId=e27fa33b priority=120)
??:??:?? 35 [Router] Found existing packet record for fr=0xc40cdd6c,to=0xffffffff,id=-494951621
??:??:?? 35 [Router] Ignoring incoming msg, because we’ve already seen it (id=0xe27fa33b Fr0x6c To0xff, WantAck0, HopLim2 Ch0xb1 encrypted rxSNR=10.25)
??:??:?? 35 [Router] Incoming message was filtered 0xc40cdd6c
??:??:?? 35 [Router] Adding packet record (id=0x542c0afa Fr0x6c To0x6c, WantAck0, HopLim0 Ch0x0 Portnum=5 requestId=e27fa33b priority=120)
??:??:?? 35 [Router] handleReceived (id=0x542c0afa Fr0x6c To0x6c, WantAck0, HopLim0 Ch0x0 Portnum=5 requestId=e27fa33b priority=120)
??:??:?? 35 [Router] Received routing from=0xc40cdd6c, id=0x542c0afa, portnum=5, payloadlen=2
??:??:?? 35 [Router] Routing sniffing (id=0x542c0afa Fr0x6c To0x6c, WantAck0, HopLim0 Ch0x0 Portnum=5 requestId=e27fa33b priority=120)
??:??:?? 35 [Router] FIXME not implemented addRoute
??:??:?? 35 [Router] FIXME not implemented removeRoute
??:??:?? 35 [Router] Received a ack for 0xe27fa33b, stopping retransmissions
??:??:?? 35 [Router] FIXME-update-db Sniffing packet
??:??:?? 35 [Router] Delivering rx packet (id=0x542c0afa Fr0x6c To0x6c, WantAck0, HopLim0 Ch0x0 Portnum=5 requestId=e27fa33b priority=120)
??:??:?? 35 [Router] Forwarding to phone (id=0x542c0afa Fr0x6c To0x6c, WantAck0, HopLim0 Ch0x0 Portnum=5 requestId=e27fa33b priority=120)
??:??:?? 35 [Router] Update DB node 0xc40cdd6c, rx_time=0
??:??:?? 35 [Router] Plugin routing considered
??:??:?? 35 Telling client we have new packets 6
??:??:?? 35 BLE notify fromNum
??:??:?? 35 BLE reading a uint32
??:??:?? 35 getFromRadio, state=5

Antenna:

hmm - that antenna looks very short. It might be you have a 433mhz unit - which would give awful range when used with the 900mhzish frequencies…

I have tried with 433MHz also and the results are not better.
How can I debug it?

hmm - I just noticed it says 915 on the antenna case so I bet that is probably fine - strike my initial theory ;-).

Is the range bad on all three? (i.e. if you use A to talk to B or C, the range is horrible. And also if you use B to talk to C the range is horrible as well)

Can you take a look at the connector that the pigtail connects to the PCB? It’s possible that either the pig tail isn’t properly seated or the connector on the PCB is poorly soldered.

1 Like