Tutorial: Setting up a Windows machine for use with Meshtastic-Python

1 Like

I’ve uploaded again on PyPI, hoping the original author will take that in the correct way.


Thanks for the quick ‘fix’!

1 Like

thank you very much!

Anyone willing to help a n00b by explaining how to install the easy-table reupload?

runpi has an issue with loading certain variables. When you enter

“meshtastic_pygui” python launches runpy to check script and this causes the error. If you use

“python -m meshtastic_pygui” you will not get the error.

Im working on trying to figure out the runpi solution so it can be ran using just meshtasitc_pygui

test performed again in a more controlled environment:

> python --version
Python 3.8.1

> virtualenv venv_meshtastic_pygui

> venv_meshtastic_pygui\Scripts\activate.bat

(venv_meshtastic_pygui) > pip install meshtastic_pygui

Successfully built pyqrcode
Installing collected packages: idna, certifi, urllib3, chardet, requests, bitstring, reedsolo, six, ecdsa, pycparser, cffi, cryptography, pyserial, esptool, PySimpleGUI, dotmap, protobuf, tabulate, pyqrcode, ptyprocess, pexpect, pypubsub, timeago, enum-compat, pygatt, meshtastic, meshtastic-pygui
Successfully installed PySimpleGUI-4.43.0 bitstring-3.1.7 certifi-2020.12.5 cffi-1.14.5 chardet-4.0.0 cryptography-3.4.7 dotmap-1.3.23 ecdsa-0.16.1 enum-compat-0.0.3 esptool-3.0 idna-2.10 meshtastic-1.2.35 meshtastic-pygui-2.6.7 pexpect-4.8.0 protobuf-3.17.1 ptyprocess-0.7.0 pycparser-2.20 pygatt-4.0.5 pypubsub-4.0.3 pyqrcode-1.2.1 pyserial-3.5 reedsolo-1.5.4 requests-2.25.1 six-1.16.0 tabulate-0.8.9 timeago-1.0.15 urllib3-1.26.4

At this point I tried both invocation methods with meshtastic_pygui.exe and python -m meshtastic_pygui but I get the same error

(venv_meshtastic_pygui) > python -m meshtastic_pygui
Traceback (most recent call last):
  File "python_64bit_3.8.1\runpy.py", line 193, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "python_64bit_3.8.1\\runpy.py", line 86, in _run_code
    exec(code, run_globals)
  File "\venv_meshtastic_pygui\lib\site-packages\meshtastic_pygui\__main__.py", line 19, in <module>
    from map3 import mapNODE
ModuleNotFoundError: No module named 'map3'
1 Like

Tried: python3 -m meshtastic_pygui and it worked but I had the same error when not running with python3

I get the same error, and it doesn’t matter if I run it with python3, py, or even directly in the python folder with ./python.

Multiple systems are giving me the same error.

Sorry everyone I went backpacking for a bit.

I fixed the error regarding “maps”, running pip install meshtastic-pygui should install everything needed now.


Man, I am trying to do this. I know nothing about this kind of stuff. I have gotten as far as downloading everything and get BASH.

I type in ./device-install.sh -f ./firmware-tbeam-1.2.43.a405d81.bin

the result is “trying to flash ./device-install.sh -f ./firmware-tbeam-1.2.43.a405d81.bin, but first erasing and writing system information python was not found; run without arguments to install from the microsoft store, or disable this shortcut from settings > manage app execution aliases”

I am on an ASUS laptop running Windows 10. I had to add “legacy hardware” in order to see PORT (COM & LPT). I was then able to see the Silicone Labs port but it still has the orange triangle/ black ! icon over it. I assume this is the problem and why it cannot find python. I am not sure and I have no idea on how to fix it.

Man, I wish I had learned more about computers…

You are doing great, the command line is tricky. What do you get when you run py -V

1 Like

If I type “py -V” it says Python 3.9.6

@beltsr Can you post a screenshot of your device manager as well as the Python error you’re getting?

this is the linux version:

sudo pip3 install --upgrade meshtastic

I can not understand the Windows Guys :smiley:

(I didn’t read this entire thread but…) I don’t think you need bash or the linux script. We also have a device-install.bat. You can run that batch file from the regular windows shell prompt.

If you run “python” from the windows shell prompt it finds the python command right? (not “py”, “python”)

on my linux not working window bar, i cant move , minimize etc windows becaus program not draw it

I had issues but you can see me work through them and get my new TTGO TBeam running and upgraded by watching a youtube video I made of the whole process: Installing Meshtastic tools on Windows, upgrading a TTgo Tbeam to 1.2.45 - YouTube

1 Like

Appreciate the time and tutorial, but there ars SO many errors, malicious (ESP) warnings, dead ends (pip), that for me, was a total waste of hours and hours of trying to make something work on two different computers and simply will not work. But again, I appreciate the time that went into the tutorial.

I did an update to the desktop gui

#-- install command
python3 -m pip install meshtastic-pygui

#-- run command
python3 -m meshtastic_pygui

  • note installing uses a hyphen and running uses an underscore

This will install, meshtastic 1.2.50 along with esptools and requests all of which are used to control the radios.

The desktop app gives you a GUI so you dont have to use the command line after it is installed. The only thing you would have to do is install python and choose 2 options which are given to you during the python install, add python to enviromental variables and install pip.