T-beam v1.1 Device not migrated

Hey everyone, newbie here. I am about to pull my hair out. I purchased two Lilygo TTGO T-Beam v1.1 devices in 2021, and am just now getting around to trying them out. Found that there have been many, many app updates, and the newest version doesn’t support the old firmware. Painstakingly installed each new version of the app on my android and updated the firmware on each device successfully through the app up to 1.3.? then the app lost the option to update, and pointed me to the web flasher. info was scant, but after some looking, I found that rather than doing this via bluetooth virtual serial port, I found a usb cable that supported data and plugged it in. That’s when I realized I needed a driver. I have now tried multiple different drivers, and the best one seems to be CH9102, but although it says device is working properly, it also says device not migrated. So while the web flasher sees the device, it cannot open the serial port. I did some more research and found the desktop python flasher for windows. It cannot detect the device. Then I found that it needs to be in boot mode? tried that, got the solid red light, still no joy.

Any suggestions? I really want this to work, but I may have to try newer devices I guess.

Well, never mind. Pulled out my wife’s old Macbook Pro, flashed with no issues at all. Wow.