Store and Forward not working. Am I missing something

New here and to Meshtastic. I have a few T-Beams and a couple T-Echos. Everything set up just fine, messaging works great out to 5 miles fairly line of site. I have one T-Beam configured as Router/Client with Store and forward enabled, but I cannot get the forward part to work.
I connected the serial debug and captured some events a associated with S&F that make me think it is storing the records, just not forwarding them.

DEBUG | 02:09:03 964 [Router] handleReceived(REMOTE) (id=0xd2645017 fr=0x82 to=0x08, WantAck=1, HopLim=3 Ch=0x0 Portnum=1 rxtime=1706753343 rxSNR=6.25 rxRSSI=-33)
DEBUG | 02:09:03 964 [Router] Module ‘StoreForward’ wantsPacket=1
INFO | 02:09:03 964 [Router] *** S&F stored. Message history contains 2 records now.
DEBUG | 02:09:03 964 [Router] Module ‘StoreForward’ considered
INFO | 02:13:02 1202 [StoreForwardModule] *** Sending heartbeat
DEBUG | 02:13:02 1202 [StoreForwardModule] Update DB node 0xe0f62c5c, rx_time=1706753582
DEBUG | 02:13:02 1202 [StoreForwardModule] handleReceived(LOCAL) (id=0x3dd498c1 fr=0x5c to=0xff, WantAck=0, HopLim=3 Ch=0x0 Portnum=65 rxtime=1706753582 priority=1)
DEBUG | 02:13:02 1202 [StoreForwardModule] No modules interested in portnum=65, src=LOCAL
DEBUG | 02:13:02 1202 [StoreForwardModule] localSend to channel 0
DEBUG | 02:13:02 1202 [StoreForwardModule] Add packet record (id=0x3dd498c1 fr=0x5c to=0xff, WantAck=0, HopLim=3 Ch=0x0 Portnum=65 rxtime=1706753582 priority=1)
DEBUG | 02:13:02 1202 [StoreForwardModule] Using AES128 key!
DEBUG | 02:13:02 1202 [StoreForwardModule] ESP32 crypt fr=e0f62c5c, num=3dd498c1, numBytes=11!
DEBUG | 02:13:02 1202 [StoreForwardModule] enqueuing for send (id=0x3dd498c1 fr=0x5c to=0xff, WantAck=0, HopLim=3 Ch=0x77 encrypted rxtime=1706753582 priority=1)
DEBUG | 02:13:02 1202 [StoreForwardModule] txGood=28,rxGood=38,rxBad=0
WARN | 02:13:02 1202 [RadioIf] Can not send yet, busyRx

I would expect that when I power on the node that was targeted with the message it would receive it after the Router Node gets an update from that node.
My radio config:
0 Private encrypted channel
1 admin
All set to client except one as Router/Client, Local Only, with S&F

Any help here would be appreciated.

TX

You need a supported client, currently only implemented on iOS

Interesting. I am using the Meshtastic app on both iPhone and mini iPad connected via bluetooth.
Curious if powering on the device, rather than re-establishing contact normally has something to do with it.
Or am I way off base and there is another client or client setup that I missed?

Thanks,

Do you have store and forward enabled on both client devices?

@garth
Yes, I have tried multiple ways. I have tried enabling store and forward with enable heartbeat, just enabling store and forward, and then just enable heartbeat alone. From the debug output it did look like the router was getting and storing the record and possibly trying to send it, but not sure if I am reading the debugs correctly.
I tried the above, because I wasn’t exactly sure how to set up. Does S&F need to be enabled on all devices wishing to use it? Initially I thought it was only the router that needed that.
You mentioned that it only works with iPhone (apple) app. Does that only have to do with the ability to enable S&F on the device? Seems strange a module would rely on the app to work.

Really would be nice to get this to work, I plan to use this network in a very remote mountainous area and there will be temporary terrain blockages. Even with a couple routers/repeaters on mountain tops.

Thanks

Needs to be enabled on all devices, one router on a tbeam with a heartbeat (try an hour)on the router

OK, I have tried every which way I can set this up to no avail.

I am running .19 firmware
Lora set to Medium-Slow
Messaging works just fine
Router-Client is T-Beam with both S&F enabled, heartbeat enabled, has private encrypted channel and admin channel. Configured to route local only.

Clients - Both T-Beam and T-Echo configured for 1 Private encrypted channel, and admin channel only.
Tried with:
No S&F enabled
Just S&F enabled
S&F Enabled, Heartbeat enabled

Router output through terminal seems to show router trying to send but stored records just seem to go up, like the client does not receive it.

Unless someone has more a more specific setup to try, I guess I will just have to wait on this feature.

TX