Recent problems building software

Hi folks,
Usually i’m doing slight modifications in the source code and then build the firmware, the recommended way, using VSC… This worked well until (including) 2.0.17.
The next one i tried to build was 2.0.20, and now 2.0.21.
To my surprise, 2.0.20 did not work on the RAK4631 but it works on the T-Beam and TLora2.2-1.6
However 2.0.21 does not work on The 4631 and on the T-Beam. I also tried to factory erease the RAK but still it doesn’t work.
Yesterday i took the normal 2.0.21.uf2 file as it comes from github, factory ereased and then flashed to the RAK4631. But even that didn’t work! Then, again factory ereasing and re-installing 2.0.17 works well.

Very strange. I can hardly imagine that the provided uf2 file doesn’t work, otherwise it would not have been released at all, or there would be bug reports after a short time.

Also i noticed that my settings on the RAK are still there, even after the factory erease.

What could be the reason for all of that? Any ideas? Does someone else notice similar behaviour?

PS: I noticed that VSC is doing some kind of updates when starting the program, which has not been the case some weeks ago. (???)

Further suspicious obervations:

Uploading 2.0.17 to the RAK4631 takes 22 seconds. Afterwards it works.

Uploading 2.0.21 (the original one) to the RAK4631 takes 4 min and 35 seconds. Afterwards it does not work. The green LED is then blinking very slowly, like a heart beat. No connection over the CLI.

Are you flashing the code from master or do you have changes locally? The released .uf2 has worked several times now on my end.

I took firmware-rak4631- from This does somehow not work.

I also do not have any problems with 2.0.21 on T-Beams and RAK4361.
If it works on neither device, maybe something went wrong with downloading or unzipping and you could try redoing that.
Also, did you follow the complete factory erase procedure for nRF as described here?

Yes, except step 6. I expect that this is not necessary and just for confirmation. But i will retry including step 6 and see what happens…

I tried to complete factory ereasy process, a few times, without success, despite the ‘Formatting… Done’ confirmation.
Also 2.0.20 (from github, without mods) does not work here. Same bahaviour as described above…

Update: firmware-rak4631- does not work either.

BUT: I (unintentionally) selected and flashed firmware-rak4631_eink- , i.e. the EINK-version. And that one works!

So maybe there is a bug somewhere and most RAK users are having the eink-screen, so they do not notice because the use they eink uf2 file?

Very few users have the eink.