Meshtastic

Problems flashing the device with any version

Both my TBeams seem to have the same issue when I try and update them. For the last 4 updates ther has been no problems.

I tried “sudo esptool.py chip_id” but the only way I can get it to complete is to use --no_stunb

Running the firmware update I get:
sudo ./device-install.sh firmware-tbeam-EU865-0.9.1.bin
Trying to flash firmware-tbeam-EU865-0.9.1.bin, but first erasing and writing system information
esptool.py v2.8
Found 2 serial ports
Serial port /dev/ttyUSB0
Connecting…
Detecting chip type… ESP32
Chip is ESP32D0WDQ6 (revision 1)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
Crystal is 40MHz
MAC: 24:62:ab:f8:74:44
Uploading stub…
Running stub…
Traceback (most recent call last):
File “/usr/local/bin/esptool.py”, line 3201, in
_main()
File “/usr/local/bin/esptool.py”, line 3194, in _main
main()
File “/usr/local/bin/esptool.py”, line 2909, in main
esp = esp.run_stub()
File “/usr/local/bin/esptool.py”, line 637, in run_stub
p = self.read()
File “/usr/local/bin/esptool.py”, line 292, in read
return next(self._slip_reader)
StopIteration

Alas no idea. It looks like something is messed up in your esptool install? Perhaps try pip3 uninstall esptool and then reinstall it?

Also possibly check if you have some other app installed that is trying to proactively open and futz with serial ports (when it should not). The linux modemmanger (sp?) module used to be notorious for this.

Thanks. I’d tried re installing, that didn’t help but after uninstalling and reinstalling everything is working as expected

1 Like