Need help troubleshooting

Hi all - so been having trouble actually communicating with nodes outside my own. I’ve triple checked the settings and can’t figure it out. I don’t know which setting could be off and not sure how to ask, but I can see other nodes on the map (mqtt) and can sometimes see what others type but not very often. Please assist if possible and thanks in advance :slight_smile: I’ll put up any necessary settings

Hey - So it looks like I’ve got the settings all right but its not working at 100%. Now I can see everyone’s chatter, real-time, but none of my test messages are being acknowledged by real humans, just says ‘Acknowledged’ , which is still better than before! Any ideas how I could start sending properly?

I’m on channel 0 primary, channel 1 secondary. I’m on MQTT and have set the server to, set username to meshdev and password to large4cats. MQTT: enabled, client proxy on, connect to MQTT on, encryption on, JSON off, and TLS off.


Did you turn on the MQTT uplink and downlink for your public channel (Settings/Channels/0)?

1 Like

Hey Jayklm, yup both Channel Zero and Channel One are uplink/downlink enabled

Hi Hiker679,

I think I had to change the name on Chan 0 to LongFast before messages started flowing.

1 Like

Hi, need some trouleshooting help using mqtt. Setup is identical as yours (mqtt enabled, all params set, network config on, etc) but I do not receive/see any messages on the default longFast channel (both up and downlink are on). Any idea what I may have missed ?

UPDATE : strangely without any changes, a couple of messages came up on the public mqtt LongFast channel, but only a couple which is weird as there must be way more chatter on this channel. So something is still wrong. Could it be the node struggling to process the volume of messages ?
I see my node on meshmap though so my status messages are sent correctly over mqtt

Hi kookcmoi, So in addition to the steps in above replies, I’ve recently tried MQTT since there aren’t any other local meshtastic devices around me yet. Changing the name of Channel 0 to LongFast (with key AQ==) and uplink/downlink enabled did help, but I tried to reconnect to MQTT at one point and there were so many users that it crashed my T-Beam every time I enabled MQTT. I’m working on learning about MQTT brokers and I’d suggest the same because it can open up other servers that aren’t as busy and you can at least get some contacts that way. You can get some info here but honestly, I’m still starting to look at it myself. It should provide new servers and login info though, eventually. Also, the hobby is growing very fast so its possible you could get more users in your area in the near future, depending on where you are and then you wouldn’t have to rely on MQTT as much but MQTT does work pretty well when it doesn’t crash your meshtastic device :wink: Hope this helps a little!

thx for this info. To be sure I understand you though, your suggestion is to create/setup its own MQTT server/broker to use instead of the default public MQTT server of the meshtastic app ?

Yes, but my only solution was given here on the forum to try MQTT Explorer. I haven’t tried it yet but it should get you to a new server, username, etc to try out. Let me know if it works for you, though, because MQTT Explorer is the only solution I’ve seen so far besides double checking all your settings. Those lucky folks in Great Britain have all kinds of contacts without MQTT but it has yet to get as popular in the US, lol. :radio:

Are you the one who developped MQTT explorer ?

By the way I made a video here explaining my MQTT config