How to configure - what am I missing?

I have a stupid question.

I have a Waveshare SX1262 module with a Raspberry Pi Pico W that I bought for using sensors to monitor some beehives. I have made some progress with my basic code for that purpose, but part of the reason I chose that hardware combo was it is on the supported hardware list for Meshtastic. So I figured I would also give Meshtastic a try. I have read that it works with the Serial Module, and I am comfortable with the serial port aspects of it.

But I’m obviously missing something in the process. I have flashed the Pico with the firmware-pico-*.uf2 files, and have been using Thonny ide to see the console. I can see Meshtastic starting and doing things. But I know i have to configure some parameters like the region frequency, etc for it to work, but i cant figure out where/how that configuration takes place.

Do I have to compile and create my own specific *.uf2 file to flash it with? Or somehow configure the supplied one? How do I enable the Serial Module? How do I issue these meshtastic command lines that I am reading about?

I promise not all my questions will be this basic. I am new to radio and new to microprocessors, so I am sure im just missing something obvious.

Thanks for any suggestions.


Pico does not have working bluetooth, so you will ned to use serial to connect via the cli, android app or web client.

Hi garth and thanks for your reply!

I understand Bluetooth and wifi don’t work on the Pico yet. And that I need to use Serial. But is the Serial module enabled by default in the supplied firmware-pico uf2 file? If so, where can i find the defult parameter settings? If not, how do i enable it?

Or am I completely misunderstanding the system architecture here, and the Serial module is not running on the Pico W?

Yes, if you’re running the latest firmware it has support for the Serial Module using GPIO pins 8 (TXD) and 9 (RXD). The module is not enabled by default, it has to be done as explained here: Serial Module Configuration | Meshtastic
E.g. follow the instructions for the CLI.

Much thanks to both of you! That was the nudge I needed in the right direction. Running meshtastic --info is telling me it’s working! Now it’s time to go back and learn more.

Thanks again!