Flash node from iPhone?

The firmware tab in the iOS app suggests using a camera adapter to flash a node.

Has any one tried it and does it work?

Hi sara41,
I am not familiar with using a camera adapter to flash a node, but I have used the nrf app as described in the docs. https://meshtastic.org/docs/getting-started/flashing-firmware/nrf52/ota/
I used the nrf app for a update just yesterday and it worked great.
Best of luck.

It works fine, you only need the adapter if your phone is lightning, USB C works without the adapter.

I have done the update with the DFU app with mixed results, the firmware linked in the Meshtastic iOS app does not work in DFU says no jason file. So have to hunt around to get the correct firmware that ends with.ota.

After having found firmware that DFU accepts, only one of several attempts was successful. Other attempts end after the boot loader step then brick the node. This requires manually plugging the node in to my Mac and dragging and dropping the firmware back on to the device. This was with multiple RAK nodes.

Using an iPhone 12 with the camera adapter, I am failing to find the RAK or T-beam to be able to drag and drop firmware to it. Where on the iPhone do I find a device connected over USB?

You have to enter DFU mode using the button in the app or by double clicking the reset button. Bricking these devices is pretty hard.

Bricked may not be the correct term, but stuck requiring more than a press of the reset button to get it back online.

At what point do I need to put the node in DFU mode?

While connected to the Meshtastic app I can use the app to put it DFU mode, but then it does not show as an available device in the DFU app.

The one time I was successful, I simply chose the RAK device (that was not linked to Meshtastic app) selected the node and pressed Upload and it worked.

They are two different dfu modes, for ble using the DFU app you don’t have to do anything, to get the device to show up as a drive on your phone you need to use either the button in the app or the reset button on the device.

From the Meshtastic app, while connected to a node via Bluetooth I can trigger DFU. But then what?

I can download the firmware, but at this point I am stumped.

I have the RAK plugged to the iPhone using the camera adapter, ( not by Bluetooth) double pressed the reset button to put it in to DFU mode. Where on the phone do find the RAK so the firmware can be loaded?

I have not yet been able to see the RAK node as device or drive on the iPhone.

The DFU lbutton in the iOS app does the same thing as double clicking the reset button, you use the files app to transfer the firmware.

In files app I should find the RAK as a Drive?
I will investigate… thanks

What my ultimate goal is, to be able to update firmware on remote nodes discreetly, through the phone would be great. I don’t want to have to take my laptop :computer: into the field. Bluetooth would be even better, but I have not had repeatable successful results as yet.

Download the firmware file (will end with -ota.zip). I download the files to the iPhone “Files” app.
The only way I have successfully updated the firmware via the iPhone is first enter DFU mode via the Meshtastic app. “Firmware Updates” …scroll to bottom of the page, click “Enter DFU Mode”.
The device will then appear on the DFU app.
Then just follow the instructions on the DFU app. Upload is slow about 6kb/s but saves a lot of hassle.

I have used the DFU app with success a few times to my solar powered nodes up a pole.
Yesterday I tried to do the same at a different site, which is on a friends roof and it failed, with the node now being unresponsive. I gather there is nothing I can do until I get the node to a computer?

That has been my experience, when it works it’s great, but if doesn’t you’ll have to manually connect to get it operating again.

1 Like

Also had mixed luck with Android but one thing I’m testing is to make sure the Meshtastic app is set to “none” first.

Not sure if that’s a factor but if the app has any Bluetooth hooks in the background it may be a problem with the nRF app also trying to connect.

It’s definitely an area that could use some improvement in reliability but it may just be a matter of being careful to have the Meshtastic app fully disconnected from any node. If it’s not that, it seems like wired is just the best way.

Reminds me that I need to get to a node that’s needing to be flashed because it failed over Bluetooth, but that one might have just been because I was impatient and didn’t get close enough to have a better connection.

1 Like

So I got an iPhone 15 with USB-C finally!
Can I do firmware updates directly wired over a cable. If so what is the process?

So is using the DFU app the only way to do a Rak update with an iPhone?

You can use files too

When I attempt the file drop method I get this error:

firmware-rak4631-2.3.13.83f5ba0.uf2 (1.4 MB)

Do I need a specific firmware format to drag and drop on iPhone?