ESP32 OLED Board V3 boards Unresponsive in Android App

I’m brand new to Meshtastic. I’ve watched a few videos, and have a few questions:

I’m in the USA and bought a couple of 915MHz LoRa ESP32 OLED Board V3 boards. They talk to each other just fine on the LongFast channel as configured in the default Meshtastic Android app, and via direct message from one to the other, so I know they’re working.

One video said by turning on “MQTT Proxy to Client” in the MQTT Config, and enabling both “Uplink” and “Downlink” in the channel setting (for the LongFast channel), the Meshtastic device should see other nodes via my phone’s internet, which they do.

  1. When I send messages out to the LongFast channel, I see an “empty” cloud signifying the message went to the net but no nodes acknowledged it… but the message -is- seen and people even answer it.

  2. Immediately after configuring my board for MQTT, I can get into the settings and change them. But, after they’ve been on MQTT for a while, I can get into the setup menu, but the app does not communicate with the board and get the information (User, Channels, Device etc). I get the progress bar, but it remains at 0%. It’s not a heat-related issue, as this occurs even if the device has been off for a number of hours. Meanwhile, the app still downloads messages from the board – after a LONG delay after they’re displayed on the board’s screen.

What can I do? I can’t connect to either of my boards and update the settings!

Thanks in advance.

More settings shot (sorry, new here, can only upload one image at a time!)

Last settings screen image:

There is a lot of traffic on the public MQTT server. Your devices are likely just overloaded, which explains why it still works immediately after enabling it, and the delay you’re seeing.

As a last resort you should be able to disable MQTT again with the CLI.

Thanks for the reply.

My non-MQTT node is currently only seeing 3 of 89 online… doesn’t seem like there’s a lot of traffic… the most recent traffic, other than that from my other node, being 3 hours ago from a station in New York City.

I went to the Android phone that’s running the MQTT node, and it was able to get data from the MQTT node, something it could not do yesterday evening. I think you’re right, it was overloaded. It seems these little ESP32 boards are pretty underpowered if they can’t handle traffic from 30 or so stations (the most I’ve seen).

It would be nice if there was a “Parrot” station where you could send it a message and it would repeat it back so you know your messages are getting out to the network.

If it’s overloaded the received messages might not even reach the phone or might not be relayed to your non-MQTT node via LoRa. When looking at the serial logs of the MQTT node you’ll see how busy it is.

Where can you look at the serial logs? Is that in the app? The debug panel?

Appreciate your continued replies to my NewB questions!

You have to connect the device to a PC with USB cable and use either the CLI option meshtastic —noproto or any other serial monitor (Putty, tio) on baud rate 115200.

Awesome. Thank you. Much appreciated.