Can't delete files

Hi, new web UI is great! One issue I have is I can’t delete files from it. I click the garbage can to the right of the file name (rangetest.csv) and nothing happens.

I opened up dev tools and nothing shows in the console. When I click the icon I see this request

Request URL: http://172.16.1.138/json/spiffs/browse/static
Request Method: GET
Status Code: 200 OK
Remote Address: 172.16.1.138:80
Referrer Policy: strict-origin-when-cross-origin
Access-Control-Allow-Methods: GET
Access-Control-Allow-Origin: *
Connection: close
Content-Type: application/json
Accept: */*
Accept-Encoding: gzip, deflate
Accept-Language: en-US,en;q=0.9
Connection: keep-alive
Host: 172.16.1.138
Referer: http://172.16.1.138/plugins
User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.93 Safari/537.36

It looks like this may not be wired up yet and just calls /json/spiffs/browse/static. I tried to delete the file after digging through git and found the following meshtastic-web/Files.tsx at master · meshtastic/meshtastic-web · GitHub which did not work.

curl -I -X "DELETE" "http://172.16.1.138/json/spiffs/delete/static?remove=static/rangetest.csv"

Is there another way to delete files or possibly a curl command that is correct?

Thanks!
Pete

I ran into the same issue and opened an issue on it with the project

2 Likes