Android - device is always sleeping

On my Android tablet which is old, my device, although paired is ALWAYS asleep. Is there a CLI command that I can send to turn off sleep?

Android app version 1.2.52

Upgrade your firmware to 1.2.52 or above, the BLE sleep (which really means the radio is off) has been removed by default.

Will do, @garth.

Thanks again!


Curious if this resolved the issue for you?

I’ve got two TTGO boards, both with the same firmware (1.2.52) each paired with a different cell phone via bluetooth. Both phones running android with the 1.2.52 android app.

One board will remain on and connected. The other will connect initially but goes immediately to sleep. It shows sleeping in the app with the message “Connected to radio, but it is sleeping”

The board will receive messages but the phone that’s connected always shows asleep and does not get the messages.

1 Like

Hi, how to update? Sorry about the silly question.

Do you have router mode on?

No, in its current state the board has been factory reset and flashed with 1.2.52 via the meshtastic-flasher on linux.

There is something i can still try on the hardware side. It looks like one of the feet on the 3d antenna is not secure. I can try to solder the feet. Not sure that would put the radio to sleep, but comparing the two boards in question its the only noticeable difference.

Any update on this, I am having similar issues?

What settings are you using?

Everything is default with latest firmware. Android app advanced set to “is_always_on”. Made sure phone bluetooth and meshtastic are not battery optimized.

Only a fraction of my message are going back and forth between two units currently showing awake.

Testing with two units in the same room does not always work right. I would stop adjusting any of the sleep settings, as they are not necessary for messaging and are likely what is causing your strange experience. The screen on a tbeam with default settings should turn off after a little while , and back on when a message or position is received. The device should never be noticeably sleeping in the android app as that feature is gone unless you turn it back on on purpose.

1 Like

there is is_always_powered, which is no longer useful for a tbeam, and is_low_power, which reverts to an old pre 1.2.52 tbeam sleep behavior. I would do a factory reset and never use either of these settings.

1 Like

Will try that, but only tried those settings “because” of sleep issues before changing any settings. Today i had a tbeam finally working, as a base, staying connected to the phone until i left it at the house, then could never connect back to it until forgetting it in bluetooth phone settings. It never actually went to “sleep” though because if it was in range it would respond with a message received icon on my other unit & phone