Disable device sleep

Good day.

I have 3 pcs. of LILYGO TTGO 433Mhz. T-Beam T22 v1.1 .
Now I have updated firmware to v1.2.45 .
My Android APP is v1.2.45 .

How can I totally disable sleep time for the devices?
Is it possible to do them “always ready” for transmit ad receive?

Thank you.

You can do this in the android app under advanced settings.

Hello Mr. @geeksville
In version 45 and below, I found a problem with sleep. Other colleagues told me about it, but I did not pay attention until I ran into it myself.
Now I am debugging a bot on a Raspberry/Orange where a constant connection of a meshtastic-device and communication via the port are required. Any connected device (homemade / tbeam / tlora) goes to sleep in a few minutes. This problem is in trouble. I tried to configure through the application the advanced setting the device slip period was set to 0, but after the reboot the command “meshtastic --port=/dev/ttyUSB0 --info” shows the value:
“Preferences: { “phoneTimeoutSecs”: 900, “lsSecs”: 86400, “region”: “RU”, “isRouter”: true }”.

I tried to put the device into “route mode”. The “–info” command shows that everything is in order and the device is in repeater mode. But, all the same, after a while the device falls asleep and the port falls off. The reset button or a complete power off helps, but again only for a few minutes.

We ask you to do something about it. For homemade devices, sleep is not so important. The problem has been reported by some users who make their own mashtastic-devices.

I’ve encountered this before in previous builds as well. Though drastic, I’ve found it best for my personal usage with constant powered home nodes to remove of the logic to determine whether or not we are running on USB power which is used in PowerFSM.cpp to determine state transitions into sleep states among other things. I just modify the isPowered method to always return true.

It’s small change that gives me some peace of mind by keeping things simple and I don’t mind doing custom firmware builds for things like this. You can make further changes or refinements to the FSM transitions in that file as well, if you’d like to alter some event occurrences.

2 Likes

Good afternoon.
The problem with sleep is still very relevant, especially for homemade DIY devices. Can anyone help without interfering with the firmware, is there a solution?

It is problematic for regular devices too, I am having all sorts of issues with the iOS app and sleeping tbeams, I would rather just turn the sleep feature off for everything but the screen.

In Platformio I cloned the latest url from meshtastic device and tried to alter PowerFSM.cpp. But the line static bool isPowered does not exist in the cpp file. Am I missing something with this way of editing the software?

1 Like

Thanks a lot for this. I will see if I can get it to work. My skills with platformio are not great. I must have missed something important when cloning. Away for a few days now hiking and using @garth’s iOS App. I will try to convert one of my tbeams to a no sleep mode. Thanks again.

Hello friends.
Latest firmware (45…46) fixed the problem a bit, but did not completely solve it. If set in advanced settings, sleep time is 0, the device responds with 8xxxx seconds. That is, the device goes into an endless sleep, instead of completely turning it off. You have to put the number 1 … 30 seconds.

I’m still pondering how to build a complete complete repeater high on the roof if I can’t get it to awake.

Does anyone have any thoughts on the topic?